
2 Using the GIMP:  
 Correcting  and  
 Touching Up Your Images

2.1 Getting Started

2.1.1 Opening and Developing a RAW Format, or “Digital 
Negative” with the GIMP

This section of the book will teach you how to open RAW files, or digital 
negatives.

If you’ve read the first chapter, you already know that the GIMP 2 can 
open most RAW formats. If you saved your photos in JPEG, you can also 
open them directly with the GIMP. Opening images directly from the 
GIMP is probably the most efficient method to touch-up your photos.

However, if you want to develop your digital negatives with a color 
depth of 16 bits per channel (rather than 8 bits) in order to make fine-tuned 
corrections and/or print a higher quality photo, you’ll need to use a plug-
in. Either RawPhoto or UFRaw will do. Once you’ve integrated one of these 
plug-ins into the GIMP, it will automatically activate when you open a 
RAW file with the GIMP. Let’s first take a look at the UFRaw plug-in since 
it can be installed standalone or as a plug-in, as described in Section 1.3.5.

UFRaw can be used in three different ways. If used as a GIMP plug-in, 
when you open a RAW file in the GIMP, the UFRaw preview window will 
automatically open. You can set corrective options for color and brightness 
values in the preview window.

You can simply click OK on an open image to load it into the GIMP. 
Then you can use the GIMP’s tools for corrections—a legitimate practice. 
Since UFRaw supports a color depth of 16 bits per color channel, this 
method allows you to make detailed adjustments while using the GIMP’s 
familiar tools. (Without UFRaw, you’d be limited to 8 bits.)

In addition, UFRaw can be used as a stand-alone program for develop-
ing digital negatives. With the UFRaw stand-alone, you can save images in 
the PPM, TIFF or JPEG file format with a 16-bit color depth per channel for 
PPM and TIFF. The example images in this section were produced with 
UFRaw stand-alone.
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Moreover, UFRaw offers a batch mode (available for the Linux plat-
form; to obtain information about this feature, enter man ufraw or ufraw—
help in the Linux console).

The main UFRaw window is designed so that the various working 
commands are displayed in the sequence in which they will be applied to 
the image. You can open an image in UFRaw and experiment with the 
options to see how they affect your image.

Figure 2.1: An unedited digital negative was 

just opened in the preview window.  

The left panes show color histograms and 

setting options.

Figure 2.2: The edited image with minor color 

corrections. Note that the left pane reveals 

the slight changes that were made on the 

Corrections curve.
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The RAW Color Histogram

The dented color curve in the top left corner of the window is the color 
histogram of your RAW image. It displays the luminosity, or the image 
brightness according to color values. The color curves beyond the histo-
gram show how the RAW data will be converted on the finished image.

Right-clicking the RAW histogram pops up a menu which allows you 
to scale and size the histogram.

Exposure

You can digitally change the original photo exposure. Increasing the expo-
sure is a simple process; the downside is that the noise in the image increases 
as you increase the exposure. Decreasing exposure is a trickier process, as it 
is impossible to recover clipped highlights.

The  Unclip Highlights option usually produces a subtle effect. 
UFRaw might clip highlights that were not clipped in the RAW file. Setting 
this option may add undesired color to your clipped highlights, so use with 
caution.

Clicking on the  Auto Adjust Exposure icon will automatically cor-
rect the exposure settings. Since the correction is done prior to setting the 
actual color, the result is not very precise. Other functions in UFRaw also 
allow you to automatically set options.

Clicking the  Reset Exposure to Default button resets the exposure 
to the program’s default values.

You will notice that there is a reset button available for every option so 
that you can undo any optional changes and revert back to UFRaw’s default 
values.

Be aware that Reset White Balance button behaves slightly differently 
than the other reset buttons. Rather than resetting UFRaw’s default values, 
this button resets the white balance to the value corresponding to the one 
that was loaded with the image. 

Bottom Line: UFRaw will “remember” any settings that you might 
have defined while editing an image; it will automatically apply those set-
tings to the next image unless you click the  Reset button to reset the 
option settings to the program default beforehand.

WB White Balance

The WB White Balance settings control the ratio between the three color 
channels. You can set the Color Temperature to make your picture warmer 
or colder. The Temperature option primarily controls the blue color chan-
nel. There is a second control for the green color channel.

In addition, you can set the white balance to Camera WB, Auto WB or 
Manual WB. You can move the controls sliders or click on the  Spot 
White Balance icon (eyedropper), then click on a white, neutral gray or 
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black area of the image. Holding the mouse button down while you drag 
the curser will increase the selected area. Clicking the eyedropper icon 
again will recalculate the white, gray, and black values of the selected 
area.

Base Curve

Base Curve offers you two choices: Linear Curve or Manual Curve. Linear 
Curve corresponds to the pre-settings of the image. Manual Curve lets you 
correct the brightness and contrast settings separately, using various bright-
ness ranges (see Section 2.4.9 on Gradation Curves).  If you click the lower 
area of the linear curve and drag it downwards while holding the left mouse 
button down, you’ll notice that the dark shades in the image become darker. 
Repeat the process for the upper area of the curve, dragging upwards this 
time, and the bright colors become brighter. By experimenting you can cor-
rect any brightness problems or just creatively play with the image. You can 
produce a color inversion of a true photo negative by dragging both end 
points of the curve vertically.

Various camera manufacturers and other sources offer similar tonal-
ity curves on their websites. You can also create curves of your own and 
save them to reuse with your images by clicking on the Diskette icon. To 
load a curve that you’ve downloaded or created on your computer, click the 
Folder icon. Also, you might want to peruse the ready-made curves found 
on Udi Fuchs’s website at http://ufraw.sourceforge.net/Contribute.html.

Color Management

Color management refers to the working color space of the mode used, 
which is mainly RGB for our purposes. You can find detailed information at 
http://ufraw.sourceforge.net/Colors.html.

Clicking the Use Color Matrix control increases color intensity, but the 
individual colors tend to overexposure or underexposure.

Corrections

Moving the Saturation slider to the right increases the color saturation of 
your image, while preserving both hue and brightness. Moving the slider to 
the left desaturates the image, reducing the colors until you have a pure 
black-and-white image.

The curve in the Corrections settings affects the brightness of the 
image. You can edit this curve in the same way as the Base Curve to increase 
image contrast. The Base Curve is intended to apply readily available curves 
to the image. When simply touching up the contrast of an image, use the 
Corrections control.
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Live Histogram

This is the histogram of the preview image, which is updated whenever you 
change the settings. By right-clicking on the live histogram, options pop up 
that allow you to set the curve’s size and representation.

There are two modes in which you can control the exposure. Clicking 
the controls or buttons underneath the Live Histogram will show you the 
Overexposed or Underexposed pixels in the image. The numerical values 
next to the controls indicate the amount of overexposure or underexpo-
sure per channel in percentages. These values provide objective informa-
tion, enabling you to correct the exposure and color settings, thus prevent-
ing a faulty exposure. Of course, the desired exposure naturally depends 
on the atmosphere you wish to create in your image.

Interpolation

The interpolation defines how the image dots should be recalculated when 
you save the final image.

The default is AHD Interpolation. It provides the best results, but may 
enhance the noise in the photo.

VNG Interpolation provides very good results.
VNG Four Color Interpolation should be used if you find Bayer pattern 

artifacts in your photo (see Section 2.4.7 on the Moiré Effect).

Bilinear Interpolation is a very basic interpolation, but it is fast.
Half-size Interpolation is the fastest interpolation method. It generates 

a single pixel out of every four original pixels. This option appears only in 

Figure 2.3: An image that was saved and 

reloaded shows a disturbing colored grid 

pattern, commonly known as Bayer pattern 

artifacts.
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the GIMP plug-in; in the stand-alone version you can achieve the same 
effect by setting the Shrink Factor in the Save As dialog to 2.

Options

All settings not directly related to image editing are hidden in the Options 
dialog. Please visit Udi Fuchs’ website at http://ufraw.sourceforge.net/Guide.
html for more information.

Saving Your Image

If you are using UFRaw as a plug-in, just click OK to send the image to the 
GIMP. The plug-in version will not save images, so you’ll have to revert to 
the GIMP’s interface in order to save your image.

In the UFRaw stand-alone version, you can save your image in either 
of two ways: Save or Save As. Clicking the Save button saves the image as 
a TIFF file in the same folder that you initially opened the RAW image in. 
You cannot select a different file name or file type with this option. If you 
hover your cursor over the Save button, a summary of where and how the 
image will be saved will pop up.

Clicking the Save As button pops up a familiar window in which 
you can select a file name, file type and folder. Windows users might 
find the file browser a bit awkward. It will be discussed in more detail 
in Section 2.2.8.

The Save Image dialog lets you choose one of three file formats: PPM, TIFF, 
and JPEG. The first two file formats will save your image in the highest qual-

Figure 2.4: The Save Image (Save As) dialog of 

UFRaw. Clicking the checkbox next to Folder 

Browser opens the folder browser.
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ity. TIFF is probably the most widely used high-quality format used when 
importing images to other programs. Both the PPM and TIFF file formats 
let you save images with either 8-bit or 16-bit color depth per color channel. 
If you opt for 16 bits, make sure that the program you’ll be using for further 
editing or when opening your image supports 16-bit color depth per chan-
nel. Remember that the GIMP is limited to 8-bit color depth.

 You should be aware that UFRaw does not yet support Embed EXIF 
Information. The feature is under development, but current builds of 
UFRaw can only embed EXIF information for Nikon NEF, Canon CR2, 
and Pentax PEF files in the JPEG image format.

If you are interested in saving EXIF information, check out the 
ExifTool by Phil Harvey.

Exchangeable Image File Format (EXIF) is a standard format devel-
oped by the Japan Electronic Industry Development Association (JEIDA) 
that modern digital cameras can use to save data. Visit http://en.wikipedia.
org/wiki/Exif for more information.

This first section focused specifically on the requirements of photogra-
phers working with RAW formats. The following chapters will explore 
requirements for working with images directly in the GIMP image editing 
program.

The Procedure

Below is a summary of preparatory steps you’ll need to take in order to 
practice the procedures described above:

After installing the GIMP on your computer, install the UFRaw plug-
in.
Insert the CD packaged with this book into your computer’s CD-ROM 
drive.
Start the GIMP. In the main window, select the File > Open menu item 
from the Toolbox to open an image (see Section 2.2.2).
Locate the CD in the File Browser and browse through the SampleImages 
folder. You will find an image labeled DSCN0071.NEF (Nikon RAW 
Format).
Double-clicking on the sample image will simultaneously launch the 
UFRaw plug-in and open the image. Have fun experimenting with the 
settings introduced above. 

2.2   Editing Images in the GIMP

2.2.1   Opening, Setting and Storing an Image—the Steps

Once you have saved an image from an external source, such as a digital 
camera, onto your computer, you can: 

r

r

r

r

r
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Open it in the GIMP
Set the size and resolution
Rotate the image
Change the image’s size on the screen (zoom in or out)
Save the image in a high quality format
Prepare it for printing

2.2.2   Opening an Image

From the File menu in the Toolbox select the menu item Open. The File 
Browser will pop up.

Double-click on the drive or directory where you want to search for an 
image in the left pane.

The middle pane will now display subdirectories, which you can dou-
ble-click on to open until you’ve found the folder containing the image you 
want.

The buttons above the search boxes show where you are within the 
specified directory path. If you’re in the wrong sub-folder, use these but-
tons to move back to the main folders and start again until you’ve found 
the appropriate file.

The middle pane will now display the files contained in the selected 
folder, sorted alphabetically by name.

You’ll notice a scrollbar on the bottom right-hand side of the Name 
box. Pull the bar up or down to quickly search through the folder.

r
r
r
r
r
r

Figure 2.5: The Open Image window.
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Now click the name of the desired image in the Name box. A preview 
of the selected image will appear in the right-hand pane.

If no preview appears, or if a message pops up telling you that no pre-
view could be created, double-click on the Preview box to get a preview of 
the image.

Once you’ve found the desired image, click on it to select it; then click 
the Open button to load it. Or just double-click the image name in the 
Name box.

A few tips:

If you’ve opened a folder that you’ll be using frequently, you can “book-
mark” it by clicking on the Add button in the left box of the window.
Clicking the All Files button will display a list of file formats the GIMP 
can read. If you select a specific format from the list, the file browser will 
only display files in that particular format.
You’ll also see an option called Determine File Type, which is set to 
Automatic by default. Clicking this button will provide a pop-up win-
dow listing file formats. If the GIMP doesn’t automatically recognize 
the format of the image you selected, you can use this option to specify 
the file format of that image.

2.2.�   The Image Window—Your Workspace

The image window is the main window that appears when you open an 
image. This is your actual workspace. Although initially the window will 
show your image in full size, you can decrease the size of your image so you 
can use the remaining space in the window to lay your palette and tools.

r

r

r

Figure 2.6: The image window.
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The blue title bar displays the image’s file name, color mode, the number of 
layers, and the original size in pixels.

In GIMP Version 2 and higher, the image window features a menu bar 
where you will find the familiar menus, such as File, Edit, View, and so on. 
We will discuss the menu items one by one later on. You will also find these 
menu items in the image window’s context menu (right-click the image 
window to open it). Some users find that it’s quicker to work within the 
context menu.

In addition, the image window is bordered at the top and left by rulers. 
By default, the rulers measure pixels (px). You can change the measuring 
unit of the rulers to inches or millimeters by clicking the pulldown menu 
in the status bar at the bottom of the window.

However, if you hover the cursor over a ruler, then left-click while 
holding the mouse button down and pulling, you can drag guides into the 
image. Guides are very helpful when checking an angle or selecting an area 
you want to crop from the image.

If you click the Magnify tool button , you will notice that the image 
inside the window will automatically adapt to whatever size you change 
the window to. 

The two smaller buttons,  and , at the bottom left serve to toggle 
the view between selection and mask modes (more about using these 
later).

Clicking the  button will reveal a small preview image of the open 
file. This is particularly helpful when you have zoomed into the image and 
want to see how a change affected the entire image without having to zoom 
out. If you hold your mouse button down, you can move around the image 
and click on the areas you want to view. You’ll notice that the larger image 
in the window will move in correlation with your movements on the pre-
view image. The section chosen with the preview image will remain in the 
main window after closing the preview window.

The status bar at the bottom of the main window also supplies useful 
information:

The upper left corner of the image will reveal the current cursor posi-
tion in pixel coordinates.
The next field from the left displays the measuring unit for the rulers. 
The default is “px” (or pixels), but you can opt to display the rulers in 
inches or millimeters.
Next, there is a hot-key for the zoom button so you can quickly enlarge 
your image.
The next field displays the name of the current layer, as well as the 
uncompressed file size of the image. When calculating a change effected 
to the image, a progress bar appears in the status line. In addition, a 
Cancel button may appear so that you can stop the process.
In general, the status bar is also used to output various values, such as 
the Measure tool.

r

r

r

r

r
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The image window (and all other windows in the GIMP) behaves like a 
typical Windows window. If you move the cursor outside the border of a 
page or to a corner point of a window, it will morph into a dual arrow, 
enabling you to manipulate the window size by dragging it while holding 
the left mouse button down. 

To move windows on the desktop, click the blue title bar and, while 
holding the left mouse button down, pull the window to the desired posi-
tion.

All program windows feature the three familiar buttons on the upper 
right corner that minimize, maximize, and close the window.

2.2.�   Rotating an Image by Fixed Values

Suppose the image you just opened is rotated 90 degrees clockwise. To set 
the image straight, click on the image with the right mouse button. The 
working menu will pop up. Select Image > Transform > Rotate 90 degrees 
CCW.

Figure 2.7: The working menu of the GIMP 

will pop up when you right-click on an open 

image.
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2.2.�  Setting the Image Size and Resolution

The image should now be upright. Next, you’ll want to set the size and reso-
lution. Let’s imagine that you want your image to be about the size of a 
photo print, 4.5 × 6.0 in, so it can easily fit on one print page. The target 
resolution of the image is 300 dpi.

Note: As mentioned earlier, you can find all necessary commands in 
the working menu located on the menu bar above the image, as well as in 
the context menu, which opens when you right-click on the image. If you 
prefer working with your mouse, the context menu should be easier and 
faster to use. However, if you prefer to work with keyboard, you’ll probably 
want to use the keyboard shortcuts. Keyboard shortcuts are displayed next 
to the corresponding menu items.

Options for setting the size and resolution are located in the image 
window; just go to Image > Scale Image.

When the Scale Image window pops up, you can set the measurement 
for Resolution X to 300 pixels/in (= dpi). In the text field, just overwrite the 
default value and press Enter to accept your changes. Both resolution val-
ues should now be 300 pixels/in.

Make sure that the chain icon near the resolution is closed, and that the X 
and Y resolutions are equal (see Figure 2.8).

The next step is to set the image size (measured in pixels, inches or 
millimeters). In the upper part of the window, you will see two values: 
Width and Height. If you want to use inches as your size unit, set inches as 
the measurement unit by clicking the arrow next to the Pixel field (to the 
right of the Height field) and select inches. Then type the number 6 for the 
value in the Height field. Press Enter to accept your changes. The value for 
the width should now be 4.5. (Be Aware: GIMP 2.2 can be a little fussy 
when changing theses values, so you may have to repeat this process more 
than once.)

Next you’ll want to select the quality of the pixel recalculation, i.e. to 
the interpolation Cubic (Best). Click to open the dropdown menu, which 

Figure 2.8: The Scaling Image window.
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was probably set on Linear by default. Click the Scale button to accept your 
changes. The program will now calculate the new image size, which will 
change as the calculation progresses. If you want to see the full image in 
the working window again, you can choose one of the various tools at your 
disposal to change the view.

2.2.� Changing the Resolution and Size

When you open an image imported from your digital camera, the GIMP 
tells you what the image dimensions are in the Image > Scale Image 
window. For example, it might read: 1200 px × 1600 px = 16.66 x 22.22 in 
= 423.33 mm × 564.44 mm with 72 ppi (ppi = pixels per inch).

If you want to modify the image to print size of, say, 4.0 × 6.0 in, you 
have to multiply the resolution using a factor of 22.22 : 6 = 3.70. The calcu-
lated value is approximately 267 ppi. For example, you would set the resolu-
tion to 267 ppi in the Image > Scale Image window and subsequently click 
the Scale button to accept your changes. The image will be recalculated to 
a size of approximately 4.5 × 6.0 in, but the number of pixels and the qual-
ity will remain roughly the same. Only the dimensions are changed. 

Your image is now ready for high-quality print. All you have to do 
before you print is to modify (or crop) the canvas to the desired size by 
using the Image > Canvas Size menu item; see Section 2.2.8).

To size your image for use on the Internet (or to send via e-mail trans-
mission or use on a webpage), simply leave the resolution at 72 ppi (or 
96 ppi) and change the dimensions in inches. This recalculation will reduce 
the number of pixels: 324 px × 432 px = 4.5 × 6.0 in with 72 ppi. In this case, 
the image must be recalculated. So select the Image > Scale Image > 
Interpolation: Cubic (Best) to create the highest quality image.

The following representation shows how resolution, image size, and 
quality interrelate:

The original as acquired from the camera.
1200 px × 1600 px = 16.667 in × 22.222 in 
with 72 ppi

The image as recalculated to 
print size: 
1200 px × 1600 px = 4.5 in × 
6.0 in with 267 ppi

The image as recalculated 
for the Internet: 
324 px × 432 px = 4.5 in × 
6.0 in with 72 ppi

Quality remains the same. Quality (number of 
pixels) is reduced.

2.2		Editing	Images	in	the	GIMP	 ��
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In other words if you choose to enlarge an image, you must reduce the reso-
lution by the factor by which you want to enlarge the image so that the 
number of pixels and, thus, the quality of the image, will remain the same. 
When printing the enlarged image, you should consider the fact that resolu-
tions of less than 150 ppi will often produce poor results, even on a modern 
inkjet printer.

There is an option to artificially enlarge an image, using interpolation 
to increase both the size and resolution of the image. This process calcu-
lates new image dots and adds them to the image. But if you enlarge an 
image beyond a certain size, it will usually become spongy and blurred.

2.2.�   Changing the Image View Size (Zooming)

Note: Changing the view size of your image will not affect the actual image 
or file size. The view options customize how you see the image on your 
computer screen, allowing for easier editing and detail work.

You can zoom in and out on an image selection by using the Magnify 
tool, which can be found in the Toolbox. Click the Magnify icon. The cur-
sor will change into a magnifier icon. Clicking the magnifier on your image 
will enlarge that particular section, and the spot where you clicked will 
become the center of the image. If you press the Ctrl button, hold it down 
and click on the image again, the image section will be reduced in size. You 
can repeat these steps until your image has been reduced or enlarged to 
your specifications.

Alternatively, you can use the zoom tool in conjunction with the left 
mouse button to pull a rectangle over the section of the image you wish to 
select. When you release the mouse button, the image you “lassoed” with 
the rectangle will be displayed in the image window.

Figure 2.9: The View > Zoom menu.
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The View > Zoom menu offers options to select the displayed size of an 
image.

Zoom Out (makes the image progressively smaller)
Zoom In (makes the image progressively larger)
Fit Image in Window (fits the image inside the existing window)
Fit Image to Window (fits the image so that it will be the exact size 
specified by the window’s width or height, rather than inside it)
Nine specific zoom levels
Other (lets you customize a scale)

The View menu also allows you to select and hide elements and attributes so 
you can work on specific areas without distractions. You can also make the 
grids and guides magnetic, which will cause tools and image objects to auto-
matically orient themselves to the guides and grids (similar to “snap to” 
functions). Two particularly interesting viewing options are:

Shrink Wrap (which resizes the window to the image height or 
width)
Full Screen (which displays the image in full screen, without a window. 
Press the Esc key to toggle to window mode)

2.2.�   Cropping (Clipping) an Image

In the previous step you reduced the image proportionally (i.e., in the same 
page ratio); therefore, you obtained a width of 4.5 in, rather that 4.0 in, the 
width you wanted.

To get a width of 4.0 in, you need to crop the image by 0.5 in.
In the Toolbox you’ll find a Crop tool (which toggles between Crop and 

Resize modes) that you can use to crop or clip your images. In the example, 
you cut 0.25 in from both the right and left margins. Now click on the 
upper left corner of the image window, and while holding down the left 
mouse button, pull it to the bottom right corner point. Then click the Crop 
button in the Crop/Resize window to crop the image. If you click the Resize 
button, the margins will be covered or hidden rather than removed. Doing 
this affects only the image size, not the working area (or canvas) which is 
what you want to do. Modifying the canvas is comparable to working with 
a photographic mount in analog photography.

In this example, however, you want to crop the image to a numerical 
measure. Go to Image > Canvas Size to access the pop-up menu for this. 
(see Figure 2.11).

The term “Canvas” is commonly used in image editing programs to desig-
nate the working area where images are placed. The canvas can be larger 
than the visible image content, but by default, the canvas size will coincide 
with the image size.

r
r
r
r

r
r

r

r

Figure 2.10: The Image menu.

2.2		Editing	Images	in	the	GIMP	 ��
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You can enlarge or reduce the canvas size without modifying the image 
it contains. By enlarging it, you create a border around the image that can 
be used to insert other image elements or text. For example, you may need 
to enlarge a canvas if you want to create a collage or paste more than one 
image on it, as shown in Section 3.12.2.

Reducing the canvas size may result in cropping the image. But in this 
case, the image size changes to the new dimensions. You can use the steps 
described below to crop the canvas by the pixel.

The Procedure

Set the measurement unit to inches.
For this example, you will crop only the width of the image. To do this, 
you must click the chain icon next to Canvas Size in the upper window 
to remove the link between width and height.
Set the value for Width to 4.0.
Next, you have to set the offset; if you do not, the image will be cropped 
on the right side only. Since you want to crop the image equally by 
0.5 in, you must set the Offset to X: -0.25 in, as 0.25 is half of 0.5 in. 
Alternatively, you can click the Center button to center and crop the 
image equally on both sides. Or you can select the image section by 
clicking the preview image and move it within the cropping frame, 
while holding down the left mouse button.
Finally, click the Resize button to crop the image. Again, only the visible 
image section will be reduced. If you want to remove image information 
which has simply been hidden thus far, an extra step is needed. Go to 
the Image > Fit Canvas to Layers menu to remove previously hidden 
image data. 

2.2.� Saving your Image

Now that you finished editing the image, it’s time to save it. In fact, it would 
be wise to make a habit of saving any image you are planning to modify 
immediately after opening it. Just save it as a new file with its own file name. 
This preparatory step will ensure that:

Your original remains unchanged
You do not overwrite your original by mistake
You can save any desired change to the new image immediately

It is recommended to use a file format such as XCF, TIFF, or PNG for your 
working image. These formats guarantee best image quality. Of course, if the 
image contains layers, the GIMP will limit your format choice to XCF or 
PSD.
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Figure 2.11: The Canvas Size window.
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Compressed files in JPEG or GIF format should be created only as cop-
ies of the original or working image.

The submenus to save images are found in the menu bar of the image 
window. The File menu offers two options:

Save simply saves your modified image onto itself. The existing version 
will be overwritten. After you close the image, you cannot undo this pro-
cess. It is highly recommended to save your image whenever you modify it 
to your liking. This will ensure that you won’t lose your work in case of a 
power outage or program crash. 

Save as: Select this option if your image is new, or if you want to save 
your image under a different file name and/or in a different file format.

You can enter a name and a file extension for the image that you intend to 
save in the text field beside Name. The Save in folder dropdown list displays 
the location where the last image you saved was stored. Click the arrow to 
display the options and select the folder you wish to store the image in. Click 
the + sign next to Browse for other folders to open a new dialog, similar to 
the Open Image dialog. This dialog will let you find and select the folder you 
want to save your image in. Or you can create a new folder by clicking the 
Create Folder button. Clicking the + sign next to the Determine File Type: 
By Extension option pops up a dialog that lets you select a (different) file 
type for the image you intend to save.

Figure 2.12: The File menu in the image 

window.

Figure 2.13: The simplest version of the Save dialog. 

The “Save in folder” dropdown list lets you select a 

storage location from your main folders or Favorites.

Figure 2.14: The Save Image dialog with all 

panes open.
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Always choose a high quality file format for saving and archiving your 
images. You can type in the desired file extension or select the desired file 
type from the Determine File Type: By Extension dropdown list in the Save 
Image dialog. The list includes the XCF, TIFF, and PNG formats, all with 
compression. It is a good idea to create a separate folder for your working 
images. (Just click on the Create Folder button in the top left part of the Save 
Image dialog.)

When you save your image, a new dialog box will pop up and give you 
the option to export the image in the desired file format, depending on the 
format you selected. Click OK to proceed.

Another dialog will now prompt for desired image file attributes. For 
the TIFF format, select LZW Compression. This compression method is 
lossless and reduces the file size. Click OK to accept. Your image is now “in 
the can”.

When exporting an image, the layers it contains can be merged into 
one background layer; that is, if you chose a file type (tif, jpg, png, etc.) 
which is unable to save layers. After the image is exported, the modified 
image will still be open in the image window.

Don’t worry: if you saved your original image prior to changing the file 
attributes, it will not be overwritten. You can quickly reopen the original 
from within the Toolbox by selecting File > Open Recent. Remember: 
Always save images with layers in a layer-enabled format (xcf or psd).

The Save a Copy item differs from the Save as. The image will be saved 
as a copy in the desired file format within the selected storage location, but 
the original will remain open in the image window.

Finally, you should be aware that you can create templates for eventual 
reuse with new images. For example, if you want to use the same dimen-
sions, resolutions, background attributes, and file format for multiple 
graphics, creating a template will save you time. Save the setting for the 
first image by accessing the File > Save as Template menu item. To reuse 
the template with a new image, select the File > New menu item and refer 
to the Template option in the pop-up dialog.

2.2.10   Printing Images

To print images from within the GIMP, you’ll obviously need to connect a 
printer to your computer, and make sure that a recent driver is installed in 
Windows. Whether your printer is connected to a parallel port or a USB 
port can be a factor. The GIMP recognizes some printers at the parallel port 
only, even though the printer works flawlessly over the USB port when 
accessed from within other programs. Ideally, you should connect your 
printer to the parallel port (normally LPT1 for Windows). If you still have 
trouble printing images from within the GIMP, you might find a solution 
from the GIMP User Group (http://gug.sunsite.dk/). For questions relating 
to GIMP under Windows, visit the WinGIMP Forum.
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Nevertheless, driver problems can arise, preventing you from printing 
directly from the GIMP program. Epson printers seem to have the most 
problems. But you can work around most of these problems by printing 
your images from within another program, such as IrfanViewer.

The Print dialog is found in the image window under the File > Print 
menu. If you installed a print program specific to your printer or other 
device (such as a scanner), a device-dependent program window will pop-
up, which you can use to configure your settings. Otherwise, the GIMP’s 
standard print window will appear.

The following settings are available in the Print dialog:

Printer (dropdown list for selecting the appropriate printer, such as the 
printer at the parallel port (LPT1), if you have more than one printer 
installed)
Print Range (to print specific pages of a multi-page document, such as 
EPS or PS [PostScript] files)
Number of Copies (to print more than one copy)

Clicking the Properties button pops up a dialog where you can set  the fol-
lowing options, depending on your printer:

Page orientation (Portrait or Landscape)
Media Choice (type of paper)
Print type (color, gray levels, or black and white)
Resolution (sometimes this is set automatically, depending on the paper 
selected)
Depending on your printer, there may be more settings available, such 
as paper size and other variables

Keep in mind that you can always burn your images on a CD and take them 
to a photo shop for exposing and printing.

Note: Most large photo shops expose with a resolution of 300 dpi and 
accept only the JPEG file format. If you plan to take your images to a photo 
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Figure 2.15: The GIMP’s Print dialog. Click the 

Attributes (Properties) button to set printer 

options.
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shop, collect and save your images in 300 dpi resolution and JPEG format 
before burning them on the CD.

2.�   Working with Scanned Images

Of course, you can use scanned images and edit them in the GIMP, in addi-
tion to images from your digital camera. The following sections give you 
important information and detailed instructions.

2.�.1   Prerequisites for Scanning

Before you can read an image from a scanner in an image editing program, 
you must properly connect the scanner to your computer and install the 
scan program that came with the device. If you work under Linux, you can 
use the XSANE interface.

What image editing programs generally do is provide a scanning con-
nection (usually referred to as the Twain source for Windows platform and 
SANE if you’re using the Linux or Mac OS). An independent scanning 
program or XSANE is necessary for scanning, and can be accessed from 
within the image editing program. Scanning under Windows is described 
in Section 2.3.2; the same process works on all operating systems.

As mentioned above, scanning under Linux is supported by the SANE 
(“Scanner Access Now Easy”) library. You can find SANE in many Linux 
distributions, including SUSE Linux. The graphical interface for scanning 
is called XSCANIMAGE or XSANE. If you’ve already installed SANE and 
XSANE, it can be accessed by going to File > Acquire > XSANE: Device 
Selection (i.e., your scanner) in the File menu of the Toolbox.

XSANE provides a graphical interface that allows you to choose 
settings for the current scan process, similar to the steps described in 
Section 2.4.2.

Additional information about SANE and XSANE can be found on the 
Internet at:

http://www.sane-project.org
http://www.xsane.org

The SANE library is also helpful for those running Mac OS X. From within 
the GIMP, it is accessed over a TWAIN-SANE interface. Mattias Ellert offers 
the required installation files (Mac OS X binary packages) for download 
from http://www.ellert.se/twain-sane.

Depending on your scanner, you may need to customize a few settings 
after installation for it to work optimally. Information regarding optimal 
scanner settings can be found at the Internet address above and on the 
SANE Project’s website at http://www.sane-project.org.
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