Copyright
This document is Copyright © 2006 by its contributors as listed in the section titled Authors.
You can distribute it and/or modify it under the terms of the Creative Commons Attribution
License, version 2.5 or later (http://creativecommons.org/licenses/by/2.5/).
All trademarks within this guide belong to their legitimate owners.

Authors
Richard Barnes
Agnes Belzunce
Daniel Carrera
Richard Detwiler
Lin M. Hall
William B. Hauck
Sigrid Kronenberger
Peter Kupfer

Ian Laurenson
Paul Miller
Daniel Rentz
Carol Roberts
Iain Roberts
John Viestenz
Jean Hollis Weber
Sue Wolff

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org

Acknowledgments
Portions of the chapter “Differences in Use Between Writer and Word” were copied (with
minor changes only) from a chapter titled “Moving from Microsoft Word” in Jean Hollis
Weber’s book, OpenOffice.org Writer: The Free Alternative to Microsoft Word published by
O’Reilly Community Press, July 2004, ISBN 0-59600-826-0.
Thanks to Jonathon Blake for information on grammar checkers in the chapter “General
Differences in Use between OpenOffice.org and Microsoft Office”.
This book was created entirely using OpenOffice.org, including writing, page layout, and
PDF creation. Most graphics were produced using OOo Draw.

Publication date and software version
Published 7 May 2006. Based on OpenOffice.org 2.0.2.

You can purchase a printed copy of this book from
http://www.lulu.com/opendocument
You can download an editable version of the chapters in this book
from http://oooauthors.org/en/authors/userguide2/published/

Contents

Contents
Chapter 1
Introduction:............................................................................................................1
What is OpenOffice.org?.............................................................................................................2
Writer (word processor).....................................................................................................2
Calc (spreadsheet)..............................................................................................................2
Impress (presentation graphics).........................................................................................2
Draw (vector graphics)......................................................................................................2
Base (database)..................................................................................................................2
Math (formula editor)........................................................................................................3
What are the advantages of OpenOffice.org?..............................................................................3
How does OpenOffice.org compare?.....................................................................................4
Features...................................................................................................................................4
Styles and formatting.........................................................................................................4
Interoperability...................................................................................................................5
Programmability................................................................................................................5
Security..............................................................................................................................5
New features in version 2.......................................................................................................6
What are the minimum requirements?........................................................................................8
How do I get the software?..........................................................................................................8
How do I install OpenOffice.org?...............................................................................................9
How do I get support?.................................................................................................................9
Free online support.................................................................................................................9
Paid support and training......................................................................................................10
Other resources and addons..................................................................................................11
What is involved in the initial migration?.................................................................................11
Sharing files..........................................................................................................................11
How do I import other files used in Microsoft Office?........................................................11
What changes do I need to make in the way that I work?.........................................................11
In general what is different in use between Microsoft Office and OpenOffice.org?............12
What are the specific differences in use between Word and Writer?...................................12
What are the specific differences in use between Excel and Calc?......................................12
What are the specific differences in use between PowerPoint and Impress?.......................12
How can I change OpenOffice.org to make it work even more like the way I have worked
in Microsoft Office?.............................................................................................................12
How do I use the Math Object editor (OpenOffice.org’s equivalent to Equation Editor)?. .12
What about that database functionality?...............................................................................12
Is there an equivalent to WordArt?.......................................................................................13
Migration Guide

i

Contents

What are the issues when migrating from WordPerfect to Writer?...........................................13
Can I open WordPerfect files in OOo?.................................................................................13
What macros are available to make Writer work more like WordPerfect?..........................13
Reveal codes....................................................................................................................13
Hanging indents...............................................................................................................13
How is OpenOffice.org licensed?..............................................................................................13
What is “open source”?.............................................................................................................14

Chapter 2
Sharing Files with Microsoft Office Users...........................................................15
File formats...............................................................................................................................16
Bulk conversion.........................................................................................................................17
Opening files.............................................................................................................................17
Opening text documents.......................................................................................................17
Opening spreadsheets...........................................................................................................18
Opening presentations..........................................................................................................18
Opening graphics files..........................................................................................................18
Opening formula files...........................................................................................................18
Saving files................................................................................................................................19
Default file format................................................................................................................19
Export to PDF and XHTML.................................................................................................20
Saving files in other formats.................................................................................................20
Writer can save to these file formats....................................................................................21
Calc can save to these file formats.......................................................................................21
Impress can save to these file formats..................................................................................21
Draw can save to these file formats......................................................................................22
The HTML writer can save in these formats........................................................................22
Object Linking and Embedding (OLE).....................................................................................22
Linked files................................................................................................................................23
WordArt and Fontwork.............................................................................................................23
Vector graphics..........................................................................................................................24
Frames and text boxes...............................................................................................................24
Active content controls..............................................................................................................24
Macros.......................................................................................................................................24
Import, export and sharing issues in text documents................................................................25
Good practice in text documents..........................................................................................25
Compatibility settings in OpenOffice.org for the current document....................................25
Add paragraph and table spacing at tops of pages (in current document).......................26
Use OpenOffice.org 1.1 tabstop formatting.....................................................................26
ii

Migration Guide

Contents

Use OpenOffice.org 1.1 line spacing...............................................................................26
Font and font spacing...........................................................................................................26
Tables....................................................................................................................................26
Mail merge documents.........................................................................................................26
Forms....................................................................................................................................27
Issues with forms created in Microsoft Office.................................................................27
Issues with forms created in OpenOffice.org...................................................................27
Footnotes, endnotes, tables of contents and indexes............................................................27
Numbered paragraphs, outline numbering, cross-references................................................28
Page numbering....................................................................................................................28
Date and time fields..............................................................................................................29
Importing Word fields...........................................................................................................29
Import, export and sharing issues in spreadsheets....................................................................30
Form fields............................................................................................................................30
Array constants.....................................................................................................................31
Optional parameters in formulas..........................................................................................31
Functions..............................................................................................................................31
Statistical, engineering and financial functions...............................................................31
Analysis ToolPak Functions.............................................................................................31
Other functions not implemented / imported...................................................................31
DataPilot—Pivot Table.........................................................................................................31
AutoFilter.............................................................................................................................32
Charts....................................................................................................................................32
Number formats....................................................................................................................33
Grid lines..............................................................................................................................33
Import, export and sharing issues in presentations....................................................................33
Color gradients and borders..................................................................................................33
Multimedia...........................................................................................................................33
Chart animations...................................................................................................................34
Pack and Go..........................................................................................................................34
Fields....................................................................................................................................34
Action settings and interaction.............................................................................................34
PowerPoint custom animations and Impress object effects..................................................34
PowerPoint—Impress slide transitions.................................................................................35

Chapter 3
Importing other Microsoft Office Files.................................................................37
Introduction...............................................................................................................................38
Custom dictionaries...................................................................................................................38
Migration Guide

iii

Contents

Create a new dictionary in OpenOffice.org..........................................................................38
Download the file that contains the macro...........................................................................39
In Microsoft Word, locate where the custom dictionaries are stored...................................39
Import the dictionary into OpenOffice.org...........................................................................39
AutoText entries........................................................................................................................40
AutoCorrect entries...................................................................................................................41

Chapter 4
General Differences in Use between OpenOffice.org and Microsoft Office........43
Help...........................................................................................................................................44
Zoom - the view percentage......................................................................................................44
AutoCorrect and AutoFormat....................................................................................................44
Menus........................................................................................................................................45
Personalized menus..............................................................................................................45
Toolbars.....................................................................................................................................46
Drag and drop............................................................................................................................46
Side panes - docked or floating windows..................................................................................46
Docking and undocking........................................................................................................47
Resizing................................................................................................................................47
Navigator..............................................................................................................................47
Styles and Formatting...........................................................................................................48
Gallery..................................................................................................................................49
Data Source Explorer...........................................................................................................50
Page preview.............................................................................................................................50
Keyboard shortcuts....................................................................................................................51
Smart tags..................................................................................................................................51
Special characters or symbols...................................................................................................51
File management.......................................................................................................................51
Default locations...................................................................................................................51
Creating new files.................................................................................................................52
Template folder management...............................................................................................52
Default templates..................................................................................................................52
Open and Save As dialogs....................................................................................................53
File management within an OpenOffice.org Open or Save As dialog.............................54
Password protection..............................................................................................................54
Privacy options.....................................................................................................................54
Digital signatures..................................................................................................................54
Portable Document Format (PDF) file creation...................................................................55
Creating web pages (HTML files) overview........................................................................55
iv

Migration Guide

Contents

Writer...............................................................................................................................55
Calc..................................................................................................................................55
Draw.................................................................................................................................55
Impress.............................................................................................................................55
Document properties............................................................................................................55
Searching for files.................................................................................................................56
Object linking between files.................................................................................................56
AutoRecovery saves.............................................................................................................56
Version control......................................................................................................................56
Working with multiple open files..............................................................................................56
Find and Replace.......................................................................................................................57
Tips for find and replace.......................................................................................................58
Attributes..............................................................................................................................58
Formats.................................................................................................................................58
Regular expressions..............................................................................................................59
Similarity search...................................................................................................................60
Search for styles....................................................................................................................60
Grammar checking....................................................................................................................60

Chapter 5
Differences in Use between Writer and Word.......................................................61
Overview...................................................................................................................................62
The Writer interface..................................................................................................................62
Views.........................................................................................................................................62
Status bar...................................................................................................................................63
Navigator...................................................................................................................................63
Formatting and Styles................................................................................................................64
Keyboard...................................................................................................................................65
How to select multiple parts of the text................................................................................65
Multiple selections and tables..............................................................................................65
Comparison of shortcut keys................................................................................................66
Mouse use..................................................................................................................................66
Tables........................................................................................................................................67
Selections involving tables...................................................................................................67
Heading rows........................................................................................................................67
Adjusting column widths and row heights using the keyboard............................................67
Copying and pasting cells in a table.....................................................................................68
Inserting and deleting rows or columns................................................................................68
Equal row heights and column widths..................................................................................68
Migration Guide

v

Contents

Splits and merges..................................................................................................................68
Sorting..................................................................................................................................69
Entering numbers and formulas............................................................................................69
Creating a table from a data source......................................................................................70
Charts in Writer.........................................................................................................................70
Customizing the user interface..................................................................................................70
Write, edit, and review documents............................................................................................71
Control page layout...................................................................................................................73
Word’s notion of page layout................................................................................................73
Writer’s notion of page layout..............................................................................................73
Comparison for page layout.................................................................................................73
Use templates and styles............................................................................................................75
Font size...............................................................................................................................76
Space between paragraphs and page breaks before..............................................................76
Fields.........................................................................................................................................76
Work with large or complex documents....................................................................................77
Work with graphics...................................................................................................................78
Mail Merge................................................................................................................................79
Envelopes..................................................................................................................................79
Adding an envelope..............................................................................................................79
Removing an envelope.........................................................................................................79
Page styles.................................................................................................................................79
Modify a page style..............................................................................................................79
Create a style........................................................................................................................79
The Page Style dialog...........................................................................................................80
Organizer tab....................................................................................................................80
Page tab............................................................................................................................80
Background tab................................................................................................................80
Header and footer tabs.....................................................................................................80
Borders, columns and footnote tabs.................................................................................81
Page breaks and page numbering..............................................................................................81
Changing the style used for a page and changing the numbering sequence.........................81
To insert page numbering.....................................................................................................81
Page numbers on portrait and landscape pages in the same place and orientation...............82
Conditional text.........................................................................................................................82
Master documents.....................................................................................................................83

vi

Migration Guide

Contents

Chapter 6
Differences in Use between Calc and Excel.........................................................85
Overview...................................................................................................................................86
The Calc interface.....................................................................................................................86
Terminology..............................................................................................................................86
User interface............................................................................................................................87
Drag and drop............................................................................................................................87
Keyboard shortcuts....................................................................................................................88
Range lists.................................................................................................................................88
Deleting cell contents................................................................................................................89
Filling down or to the right.......................................................................................................89
Using the Fill Down (or Fill Right) feature..........................................................................89
Using the fill handle.............................................................................................................89
Default number format..............................................................................................................90
Interpreting cell contents...........................................................................................................90
Limitations................................................................................................................................90
Form fields................................................................................................................................91
Relative addressing of sheets....................................................................................................91
Named ranges and “Natural Language” formulas.....................................................................91
Array formulas..........................................................................................................................91
Functions...................................................................................................................................92
Optional parameters in functions..........................................................................................92
Date values in financial functions........................................................................................93
Analysis Addin functions......................................................................................................93
Differences in function results..............................................................................................93
Functions not implemented or imported...............................................................................93
DataPilot or Pivot Table............................................................................................................94
AutoFilter..................................................................................................................................94
Inserting notes (“comments” in Excel).....................................................................................95
Text to columns.........................................................................................................................96
Solver........................................................................................................................................96
Charts........................................................................................................................................96
Number formats.........................................................................................................................96
Use of Autosum feature.............................................................................................................97
Grid lines and other view settings.............................................................................................97
Hidden rows..............................................................................................................................97
Navigator...................................................................................................................................97
Styles and Formatting window..................................................................................................98

Migration Guide

vii

Contents

Conditional formatting and styles.............................................................................................98
Function list...............................................................................................................................99
Error values...............................................................................................................................99
Working across spreadsheets, web pages and database data.....................................................99
Working across spreadsheets................................................................................................99
Links to HTML data or other spreadsheets........................................................................101
Links to database data.........................................................................................................101
Printing....................................................................................................................................102
Macros.....................................................................................................................................104
Number recognition.................................................................................................................104
Default cell formats............................................................................................................104
Input category.....................................................................................................................106
Changing the cell’s format based on input.........................................................................107
Pasting values.....................................................................................................................107

Chapter 7
Differences in Use between Impress and PowerPoint........................................109
Introduction.............................................................................................................................110
Accessing different views........................................................................................................110
Color gradients and borders.....................................................................................................112
Multimedia..............................................................................................................................112
Narration.............................................................................................................................112
Sound..................................................................................................................................112
Chart animations......................................................................................................................112
Pack and Go.............................................................................................................................113
Fields.......................................................................................................................................113
Action settings and interaction................................................................................................113
Animating a slide show...........................................................................................................113
Custom animations.............................................................................................................113
Differences in animation effects.........................................................................................115
Slide transition effects........................................................................................................116
Fitting text to a frame..............................................................................................................117

Chapter 8
Customizing OpenOffice.org...............................................................................119
Customizing toolbars..............................................................................................................120
Customizing toolbars..........................................................................................................120
Creating a new toolbar........................................................................................................121
Customizing menus.................................................................................................................121
Customizing menu content.................................................................................................121
viii

Migration Guide

Contents

Customizing the menu font................................................................................................122
Customizing shortcut keys......................................................................................................123
Customizing word entry and editing.......................................................................................124
AutoCorrect/AutoFormat...................................................................................................124
Undo and redo....................................................................................................................125
Checking spelling...............................................................................................................125
Installing other language dictionaries.................................................................................125
Security settings......................................................................................................................125
Personal settings......................................................................................................................125
Storing configurations in a template.......................................................................................126

Index......................................................................................................................127

Migration Guide

ix

Migration Guide

Chapter 1
Introduction:
Migrating to OpenOffice.org from other office suites

What is OpenOffice.org?

What is OpenOffice.org?
OpenOffice.org (OOo) is a freely-available, full-featured office suite. It includes the
following components.
Writer (word processor)

Writer is a feature-rich tool for creating letters, books, reports, newsletters,
brochures, and other documents. You can insert graphics and objects from other
components into Writer documents. Writer can export files to HTML, XHTML,
XML, Adobe’s Portable Document Format (PDF), and several versions of
Microsoft Word files. It also connects to your email client.
Calc (spreadsheet)

Calc has all of the advanced analysis, charting and decision-making features
expected from a high-end spreadsheet. It includes over 300 functions for financial,
statistical and mathematical operations among others. The Scenario Manager
provides “what if” analyses. Calc generates 2-D and 3-D charts, which can be
integrated into other OOo documents. You can also open and work with Microsoft
Excel workbooks and save them in Excel format. Calc can export spreadsheets to
Adobe’s Portable Document Format (PDF) and to HTML.
Impress (presentation graphics)

Impress provides all the common multi-media presentation tools, such as special
effects, animation, and drawing tools. It is integrated with the advanced graphics
capabilities of the Draw and Math components. Slideshows can be further
enhanced with Fontwork’s special effects text, as well as sound and video clips.
Impress is compatible with Microsoft’s PowerPoint file format, and can save your
work in numerous graphics formats including Macromedia Flash (SWF).
Draw (vector graphics)

Draw is a vector drawing tool that can produce everything from simple diagrams or
flowcharts to 3-D artwork. Its Smart Connectors feature allows you to define your
own connection points. You can use Draw to create drawings for use in any of
OOo’s other components, and you can create your own clipart and add it to the
Gallery. Draw can import graphics from many common formats and save them in
over 20 formats including PNG, HTML, PDF and Flash.
Base (database)

Base offers tools for day-to-day database work within a simple interface. It can
create and edit forms, reports, queries, tables, views and relations, so managing a
connected database is much the same as in other popular database applications.
Base provides many new features, such as the ability to analyze and edit
relationships from a diagram view. Base incorporates HSQLDB as its default
relational database engine. It can also use dBASE, Microsoft Access, MySQL or
Oracle, or any ODBC or JDBC compliant database. Base also provides support for
a subset of ANSI-92 SQL.
2
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Math (formula editor)

Math is OOo’s formula or equation editor. You can use it to create complex
equations that include symbols or characters not available in standard font sets.
While it is most commonly used to create formulas in other documents, such as
Writer and Impress files, Math can also work as a stand-alone tool. You can save
formulas in the standard Mathematical Markup Language (MathML) format for
inclusion in web pages and other documents not created by OOo.

What are the advantages of OpenOffice.org?
Here are some of the advantages of OpenOffice.org over other office suites:
•

No licensing fees. OOo is free for anyone to use and distribute at no cost. Many
features that are available as extra cost add-ins in other office suites (like PDF export)
are free with OOo. There are no hidden charges now or in the future.

•

Open source. You can distribute, copy, and modify the software as much as you wish,
in accordance with either of OOo's Open Source licenses.

•

Cross-platform. OOo 2.0 runs on several hardware architectures and under multiple
operating systems, such as Microsoft Windows, Mac OS X, Linux, and Sun Solaris.

•

Extensive language support. OOo’s user interface is available in over 40 languages
and the OOo project provides spelling, hyphenation and thesuarus dictionaries in over
70 languages and dialects. OOo also provides support for both Complex Text Layout
(CTL) and Right to Left (RTL) layout languages (such as Hindi, Hebrew and Arabic).

•

Consistent user interface. All the components have a similar “look and feel”, making
them easy to use and master.

•

Integration. The components of OpenOffice.org are well integrated with one another.
• All the components share a common spelling checker and other tools, which are
used consistently across the suite. For example, the drawing tools available in
Writer are also found in Calc, with similar but enhanced versions in Impress and
Draw.
• You do not need to know which application was used to create a particular file (for
example, you can open a Draw file from Writer).

•

Granularity. Usually, if you change an option, it affects all components. However,
options can be set at a component level or even document level.

•

File compatibility. OOo includes PDF and Flash export capabilities, as well as
support for opening and saving files in many common formats including Microsoft
Office, HTML, XML, WordPerfect and Lotus 123 formats.

•

No vendor lock-in. OOo 2.0 uses OpenDocument, an XML (eXtensible Markup
Language) file format developed as an industry standard by OASIS (Organization for
the Advancement of Structured Information Standards). These files can easily be
unzipped and read by any text editor, and their framework is open and published.
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•

You have a voice. Enhancements, software fixes and release dates are communitydriven. You can join the community and affect the course of the product you use.

You can read more about OpenOffice.org, its mission, history, licensing and other
organizational information here: http://www.openoffice.org/about.html

How does OpenOffice.org compare?
OpenOffice.org can match and exceed the feature set of competing office suites. The
following table lists the main components of OOo and compares them with their equivalents
in two leading office suites, Microsoft Office 2003 (MSO) and WordPerfect Office 12 (WP).
Function

OOo

MSO

WP

Word processor

Writer

Word®

WordPerfect®

Spreadsheet

Calc

Excel®

Quattro Pro®

Vector Graphics

Draw

no

no

Presentation Graphics

Impress

PowerPoint®

Presentations®

Database

Base

Access®

Paradox® 2

Math or Formula Editor

Math

yes

1
2

1

no

Professional version only.
Professional and Student and Teacher editions only.

Features
The following tables list some important features of OpenOffice.org and compare them with
two leading office suites, Microsoft Office 2003 (MSO) and WordPerfect 12 (WP).
Styles and formatting
Feature

OOo

MSO

WP

Navigator

yes

limited1

no

Styles and Formatting window

yes

yes

no

Keyboard support for paragraph styles

yes

yes

no

Support for page, frame, and list styles

yes

no

no

Word completion

yes

Excel only

no

Spelling and language proofing modules

70+

50+

25

Formula or equation tools

yes

yes

1
2

4

2

no

“Outline View” in Word offers a subset of the features of OOo’s Navigator.
Requires an additional license for the the Multilingual User Interface Pack.
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Interoperability
Feature

OOo

MSO

WP

PDF export capability

yes

no

yes

Flash export capability

yes

no

yes

XML export capability

yes

yes

yes

OpenDocument XML format

yes

no

no

Import/Export Microsoft Office files

yes

yes

yes

Import WordPerfect files

yes

yes

yes

Import Lotus 123 files

yes

yes

yes

Connect to external databases (MySQL,
Oracle, Access, etc.)
Languages available (localizations)

yes

yes

yes

40+

35+

Supported operating systems

Unicode language support
1

24

Windows, Mac
OS X, Linux,
Solaris

Windows only

Windows
only

yes

yes

no

1

Microsoft Office: Mac is not feature compatible with Microsoft Office 2003.

Programmability

Macros are programs which automate tasks and can be embedded in a document. The
following table lists the languages available for macro development in each office suite.
Language

OOo

MSO

WP

OpenBasic

VBA

VBA

Beanshell

yes

no

no

Java

yes

no

no

JavaScript

yes

no

no

Python

yes

no

no

Basic-derived language

Beyond simple macros, some office suites can be extended to include new features. This
capability usually takes the form of plug-ins. In the case of OpenOffice.org, it can also be
done through changes to the source code.
Feature

OOo

MSO

WP

C and C++

yes

yes

yes

Java

yes

no

no

Python

yes

no

no

Source code available!

yes

no

no

Security
Chapter 1 Introduction:
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Feature

OOo

MSO

WP

Digital signatures

yes

yes

yes

Strong encryption

yes

yes

yes

Secure paths for macro execution

yes

yes

no

New features in version 2
OpenOffice.org 2.0 delivers hundreds of improvements and new features. Here are some of
the major enhancements.

•
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•

Simplified installation. Installations are now performed by platform-native installers
with no need to use command-line switches (or flags) for multi-user installations. You
can also specify which version of Java (if any) is to be used by OOo from the
installation interface.

•

New database component. In the new stand-alone database component, you can
create forms, reports, queries, tables, views and relations. OOo now includes
HSQLDB, a small, fast, relational database engine that supports a subset of ANSI-92
SQL, along with an easy to use interface. Additionally, it is now easier than ever to use
other databases (dBASE, MySQL, Oracle, among others).

New file format. OOo 2.0 uses the new OpenDocument standard XML file format
(standardized by OASIS, http://www.oasis-open.org/home/index.php) as its default file
format. This new file format is also used in StarOffice, IBM Workspace and KOffice, and
will be used by other products in the future. OOo 2.0 can still read and save files in formats
previously supported by
OOo 1.x, including Microsoft Office formats.
•

Native system theme integration. To further integrate OpenOffice.org with the
underlying operating system, all user interface elements (such as buttons and
scrollbars) have the same look as those used in other native applications for each
platform.

•

Digital signatures. Digital signatures provide authentication of the true author or
editor of a document. This feature provides further security with running macros.

•

Enhanced encryption. Implementation of the new XML (eXtensible Markup
Language) encryption algorithm offers additional document security.

•

Usability improvements. Redesigned toolbars are more usable, and display only
selected default tools and related options. The usability of the Menus tab of the Tools
> Customize dialog has been improved. Several features have been renamed to
conform with common office suite terminology (for example, “AutoPilot” is now a
“Wizard”).
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•

Thumbnails. The new plug-in for the the native file explorer provides a thumbnail
preview of an OOo file. Some of the more common file system explorers that can use
this new feature are Nautilus (Gnome), Konqueror (KDE), and Microsoft Windows
Explorer.

•

Import and export filters
• Improved PDF export filter now includes PDF bookmarks, PDF notes, and more.
•

Import and export of Microsoft Office 95 and Office 97 spin buttons and scrollbars
have been added to the Word filters.

•

The import filter for Microsoft PowerPoint documents now creates text objects
having font-independent line spacing enabled.

•

Enhanced export to HTML produces valid “XHTML 1.0 Strict” documents.
XHTML export has been enabled for Calc, Draw and Impress.

•

You can now open Microsoft Office password-protected documents.

•

New import filters for WordPerfect and Lotus 123.

•

Send document as e-mail. OOo 2.0 makes it easier to use your email client to send
the active document as an attachment.

•

Enhanced mail merge feature. Enhancements include better management of
databases and saving into one single file.

•

Drag and drop selections to create styles. Drag and drop a text selection into the
Styles and Formatting window to create a new paragraph style or character style.

•

Form controls. Form controls can be embedded in all OOo documents that support a
form layer.

•

New keyboard shortcuts. You can now use the keyboard to perform the actions found
under Edit > Paste Special. Multiple selected sheets in a spreadsheet can be
deselected using the keyboard. Paragraph and other styles can be assigned to key
combinations.

•

Auto recovery of files and the workspace environment. The OOo Error Reporting
tool and the document recovery features have been combined. Now if OOo crashes,
the active documents are saved. You can recover the documents, and send an error
report.

•

Enhanced features in Calc. These enhancements include improved number
recognition, an improved Hyperlink function, conditional arrays, a greater selection of
predefined headers and footers, more options for defining how to print sheets, new
options for the DataPilot feature, and support for right-to-left languages.

•

Calc row limit increased. The number of spreadsheet rows has been increased to
65536, the same number of rows as Microsoft Excel.
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•

Enhanced multimedia. The multimedia presentation model uses the W3C’s
Synchronized Multimedia Integration Language (SMIL) standard. Now Impress can
render nearly all of the Microsoft PowerPoint animation effects. Two new task panels
provide access to shape and slide transition effects.

•

Programmatic control of menu and toolbar items. Third-party developers can write
plugins to manipulate menu bar and toolbar layouts to their needs. Developers can
now insert, remove, and modify menu items, context menus, and toolbar items at
runtime.

•

Scripting framework. The scripting framework allows you to write macros in a
number of languages other than OOo Basic. You can assign these macros to menu
items, keyboard combinations, application and document events, form controls within
documents, and various objects within documents.

For a complete, detailed listing, go to the OpenOffice.org 2.0 Office Suite, Guide to New
Features located at http://marketing.openoffice.org/2.0/featureguide.html#enduser

What are the minimum requirements?
OpenOffice.org 2.0 requires one of the following operating systems:
•

Microsoft Windows 98, Windows ME, Windows 2000 (Service Pack 2 or higher),
Windows XP or Windows 2003

•

GNU/Linux Kernel version 2.2.13 and glibc 2.2.0 or newer

•

Mac OS X 10.3.x (10.3.5 recommended), Mac OS X 10.4.x, plus X11

•

Solaris version 8 or higher

More operating systems will be supported in the future.
Some OpenOffice.org features (wizards and the database component) require that the Java
Runtime Environment (JRE) be installed on your computer. Although OOo will work fine
without Java support, some features will not be available. You can download the latest
version from http://www.java.com.
For a more detailed (and up-to-date) listing of requirements, see:
http://www.openoffice.org/dev_docs/source/sys_reqs_20.html

How do I get the software?
You can get the OpenOffice.org installation package in any of these ways:
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•

Download a copy from the project’s home page: http://www.openoffice.org.

•

Download a copy using the Peer to Peer client, BitTorrent. The instructions are here:
http://distribution.openoffice.org/p2p/download.html.
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•

Purchase a copy on a CD-ROM or other digital form from a third party distributor. The
project maintains a listing of distributors; however these distributors are not connected
with, nor endorsed by OpenOffice.org:
http://distribution.openoffice.org/cdrom/sellers.html.

•

The OpenOffice.org Porting Project has links to versions of the software that have
been, or are currently being “ported” to run under various operating systems.
http://porting.openoffice.org/index.html.

How do I install OpenOffice.org?
Information on installing and setting up OpenOffice.org on the various supported operating
systems is given here: http://download.openoffice.org/2.0.2/instructions.html
You can also download the more detailed Setup Guide (in several languages) from
http://documentation.openoffice.org/setup_guide2/index.html

How do I get support?
OOo comes with an extensive Help system. This is your first line of support for using OOo.
To display the full Help system, press F1 or select OpenOffice.org Help from the Help
menu. In addition, you can choose whether to activate tooltips, extended tips, and the Help
Agent (using Tools > Options > General).
If tooltips are enabled, place the mouse pointer over any of the icons to see a small box
(“tooltip”) with a brief explanation of the icon’s function. For a more detailed explanation,
select Help > What's This? and hold the pointer over the icon.

The Help menu

Free online support
The OpenOffice.org community not only develops software, but provides free, volunteerbased support. Users of OOo can get comprehensive online support from community venues
such as newsgroups, forums or mailing lists. There are also numerous websites run by users
that offer free tips and tutorials.
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Free OpenOffice.org support
User Help – FAQ Project

Users Mailing List

FAQs, information, knowledge base.
http://user-faq.openoffice.org/new-faq/index.html
Free community support provided by a network of hundreds
of experienced users. You must be subscribed to post
messages.
To subscribe, send a blank email to
users-subscribe@openoffice.org
List archives are here:
http://www.openoffice.org/servlets/SummarizeList?
listName=users

Documentation Project

Templates, user guides, how-tos, and other documentation.
http://documentation.openoffice.org/

Native Language Project

Information, resources, and mail lists in your language.
http://projects.openoffice.org/native-lang.html

Mac Support

Support for installing and using the Mac OS X (X11 based)
port. http://porting.openoffice.org/mac/support.html

The OpenOffice.org Forum

Extensive discussion forum for OpenOffice.org issues from
setup to advanced programming features.
http://www.oooforum.org/

OOo KnowledgeBase

A collection of questions and answers that users can query.
http://mindmeld.cybersite.com.au/

Read more about the support options for OpenOffice.org at:
http://support.openoffice.org/index.html

Paid support and training
Alternatively, you can pay for support services. Service contracts can be purchased from a
vendor or consulting firm specializing in OpenOffice.org.
OOo is supported by Sun Microsystems, Inc. under the Sun Software Support program,
which includes two levels of support that cover extended business hours or around-the-clock
service for mission-critical deployments.
http://www.sun.com/service/support/software/openoffice/index.html
A list of independent consultants and the services they offer, listed alphabetically by region
and then by country, is provided on the OpenOffice.org website.
http://bizdev.openoffice.org/consultants.html
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Other resources and addons
Several websites provide additional free resources and addons to enhance OpenOffice.org.
The following table lists a few of these websites.
Free OOo templates, artwork and other addons
OOExtras

Provides templates, samples and macros in several languages.
http://ooextras.sourceforge.net/

OOoMacros

A repository for OOo macros and addons, and documentation
about writing macros and/or extending OOo.
http://www.ooomacros.org/

Open Clip Art Library

An archive of clip art that can be used for free for any use.
http://www.openclipart.org/

OpenOffice.org Macro
Information

Andrew Pitonyak, the author of OpenOffice.org Macros
Explained, maintains this site which provides extensive
documentation on OOo's macro capability. Many good referral
links are also provided at: http://www.pitonyak.org/oo.php

What is involved in the initial migration?
Sharing files
See Chapter 2, “Sharing Files with Microsoft Office Users” in this guide for information
about opening and saving files of various formats.

How do I import other files used in Microsoft Office?
See Chapter 3, “Importing other Microsoft Office Files” in this guide for information about
importing custom dictionaries, AutoCorrect entries and AutoText entries into OpenOffice.org.

What changes do I need to make in the way
that I work?
While the interfaces of OpenOffice.org and Microsoft Office are sufficiently similar to allow
immediate productivity, they are not identical. Some functions are based on different
underlying concepts. The chapters in this guide will to help you with these differences.
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In general what is different in use between
Microsoft Office and OpenOffice.org?
See Chapter 4, “General Differences in Use between OpenOffice.org and Microsoft Office”
in this guide first, as it gives an overall view of differences; the other chapters build on the
information presented in that chapter.

What are the specific differences in use between
Word and Writer?
See Chapter 5, “Differences in Use between Writer and Word” in this guide for specific
information related to text documents.

What are the specific differences in use between
Excel and Calc?
See Chapter 6, “Differences in Use between Calc and Excel” in this guide for specific
information related to spreadsheets.

What are the specific differences in use between
PowerPoint and Impress?
See Chapter 7, “Differences in Use between Impress and PowerPoint” in this guide for
specific information related to presentations.

How can I change OpenOffice.org to make it work
even more like the way I have worked in Microsoft
Office?
See Chapter 8, “Customizing OpenOffice.org” in this guide for information about changing
OpenOffice.org to make it work your way. That chapter includes links to macros that were
written to help ease the transition.

How do I use the Math Object editor
(OpenOffice.org’s equivalent to Equation Editor)?
See Chapter 16 “Math Objects” in the Writer Guide.

What about that database functionality?
See Chapter 10 “Getting Started with Base” in the Getting Started guide, and the Database
Guide for details on the new Base component of OpenOffice.org.
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Is there an equivalent to WordArt?
Yes. See Chapter 15 “Using Fontwork” in the Getting Started guide.

What are the issues when migrating from
WordPerfect to Writer?
Can I open WordPerfect files in OOo?
Yes, a WordPerfect filter is now available in the standard OpenOffice.org installation.

What macros are available to make Writer work
more like WordPerfect?
Reveal codes

OpenOffice.org’s Writer does not have underlying codes in the same way that WordPerfect
does. But a macro is being written that will allow you to work in a similar way to
WordPerfect’s reveal codes. See RevealCodes3.sxw available at
http://homepages.paradise.net.nz/hillview/OOo/ for more information.
Hanging indents

The hanging indent concept in Writer is quite different from the concept used in WordPerfect.
The best approach in OpenOffice.org is to use styles, but to ease the transition, see either
AltKeyHandler.sxw or Indents.sxw available from
http://homepages.paradise.net.nz/hillview/OOo/ for a macro that approximates WordPerfect’s
way of implementing hanging indents.

How is OpenOffice.org licensed?
OpenOffice.org is distributed under the Open Source Initiative (OSI) approved Lesser
General Public License (LGPL). The LGPL can be viewed on the OOo website at:
http://www.openoffice.org/licenses/lgpl_license.html
For more general information on OOo’s licensing, please refer to:
http://www.openoffice.org/license.html.
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What is “open source”?
The ideals of open-source software can be explained by the four essential rights, which are
embodied within the Free Software Foundation’s General Public License (GPL):
•

The right to use the software for any purpose.

•

Freedom to redistribute the software for free or for a fee.

•

Access to the complete source code of the program (that is, the “blueprints”).

•

The right to modify any part of the source, or use portions of it in other programs.

Another view of this philosophy comes from the Open Source Definition:
“The basic idea behind open source is very simple: When programmers can read,
redistribute, and modify the source code for a piece of software, the software evolves.
People improve it, people adapt it, people fix bugs. And this can happen at a speed that, if
one is used to the slow pace of conventional software development, seems astonishing.”
For more information on Free and Open Source software, visit these websites:
Open Source Initiative (OSI): http://www.opensource.org
Free Software Foundation (FSF): http://www.gnu.org
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Chapter 2
Sharing Files with
Microsoft Office Users

File formats

File formats
This section gives a simplified overview of OpenOffice.org’s file format.
OpenOffice.org stores its files in a compressed (zipped) XML format. This format is humanly
readable when unzipped. It is openly documented and is publicly available under the GNU
License (http://www.gnu.org).
For details about XML formats, see http://books.evc-cit.info/book.php.
Note

Some compression utilities only check the file extension and may not recognize the
file as being compressed. To open an OpenOffice.org file with such a compression
utility, you can rename the file to have the extension .zip.

By contrast, Microsoft Office files are stored in a proprietary format which is not human
readable and not publicly documented. This causes problems for software developers writing
filters for importing and exporting in Microsoft Office formats.
In OpenOffice.org 2.0 there has been a small change in file format and extension from that
used in OpenOffice.org1.1.x. The change is due to decisions by the open standards committee
OASIS. Other applications, for example KOffice, are also using the same format.
Table 1. File extensions for OpenOffice.org 2.0. (OOo 1.1.x extensions are shown in brackets).
Document type

Application

Extension

MS Office equiv

Text

Writer

odt (sxw)

doc

Text Template

Writer

ott (stw)

dot

Master Document

Writer

odm (sxg)

doc

HTML document

Writer

html

html

Spreadsheet

Calc

ods (sxc)

xsl

Spreadsheet Template

Calc

ots (stc)

xst

Drawing

Draw

odg (sxd)

N/A

Drawing Template

Draw

otg (std)

N/A

Presentation

Impress

odp (sxi)

ppt

Presentation Template

Impress

otp (sti)

pot

Formula

Math

odf (sxm)

N/A

Chart

Chart

odc

N/A

Database

Base

odb

mdb
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Note

OpenOffice.org can open Microsoft Office files. The reverse is not true: at this time,
Microsoft Office can not open OpenOffice.org formats.
If you need to send files to someone using Microsoft Office, save your file first in
the native OpenOffice.org format, then save it to one of the many supported
Microsoft Office formats. By doing this, you ensure that even if the filter can not
translate perfectly, you have your original in its native format.
OpenOffice.org can not open or convert Microsoft Access files (.mdb) files directly,
however it can access the data in the tables using DAO and ODBC. See the
Database Guide for more information.

Bulk conversion
To use OpenOffice.org to convert a lot of files, click File > Wizards > Document
Converter.
Before doing a bulk conversion of files, think about whether it is really necessary. Read this
document right through to get an appreciation of the limitations of the conversion process.
Note

Converting a lot of files can take a long time. I recommend you check for sufficient
disk space first, and start converting when the computer is not going to be used for a
while. In general, OOo files take up less space than Microsoft Office files, but to be
safe you might allow for the same amount of space for the converted files.

Opening files
Opening text documents
In addition to the native OpenDocument formats (.odt and .ott), OpenOffice.org Writer 2.0
can import the following text document formats:
Microsoft Word 6.0/95/97/2000/XP) (.doc, .dot)
Microsoft Word 2003 XML (.xml)
Microsoft Winword 5 (.doc)
StarWriter formats (.sdw, .sgl, .vor)
AportisDoc (Palm) (.pdb)
Pocket Word (.psw)

WordPerfect Document (.wpd)
WPS 2000/Office 1.0 (.wps)
DocBook (.xml)
Ichitaro 8/9/10/11 (.jtd, .jtt)
Hangul WP 97 (.hwp)
.rtf, .txt, .csv

When opening .HTM or .HTML files, OpenOffice.org customizes Writer for working with
these files.
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Opening spreadsheets
In addition to the native OpenDocument formats (.ods and .ots), OpenOffice.org Calc 2.0 can
open the following spreadsheet formats:
Microsoft Excel 97/2000/XP (.xls, .xlw, .xlt)
Microsoft Excel 4.x–5/95 (.xls and .xlw, .xlt)
Microsoft Excel 2003 XML (.xml)
Data Interchange Format (.dif)
dBase (.dbf)
.htm and .html files including Web page queries
Quattro Pro 6.0 (.wb2)

Rich Text Format (.rtf)
Text CSV (.csv and .txt)
Lotus 1-2-3 (.wk1 and .wk1)
StarCalc formats (.sdc, .vor)
SYLK (.slk)
Pocket Excel (pxl)

Opening presentations
In addition to the native OpenDocument formats (.odp and .otp), OpenOffice.org Impress 2.0
can open the following presentation formats:
Microsoft PowerPoint 97/2000/XP (.ppt, .pps)
Microsoft PowerPoint 97/2000/XP Template
(.pot)

Computer Graphics Metafile (.cgm)
StarDraw, StarImpress (.sda, .sdd, .sdp,
.vor)

Opening graphics files
In addition to the native OpenDocument formats (.odg, and .otg), OpenOffice.org Draw 2.0
can open the following graphic formats:
BMP
DXF
EMF
EPS
GIF

JPEG, JPG
MET
PBM
PCD
PCT

PCX
PGM
PLT
PNG
PPM

PSD
RAS
SDA
SDD
SGF

SGV
SVM
TGA
TIF, TIFF
VOR

WMF
XBM
XPM

Opening formula files
In addition to OpenDocument Formula files, OpenOffice.org Math 2.0 can open the StarMath
(.smf) and MathML (.mml) files.
When opening a Word document that contains an embedded equation editor object, select the
[L] checkbox for MathType to OpenOffice.org Math/OpenOffice.org Math to MathType in
Tools > Options > Load/Save > Microsoft Office and the object will be automatically
converted to an OpenOffice.org Math object.
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Saving files
Default file format
OpenOffice.org saves files in the OpenDocument format by default unless told otherwise.
This default can be changed, for example if you always want to save as Microsoft Office
files. To change the default file formats:
1) Go to Tools > Options > Load/Save > General. (See Figure 4.)

Figure 1. Choosing default formats for saving files
2) In the Standard File Format section of this page, choose a document type (for example,
“Text document”) and a file format from the Always save as list.
3) Repeat for each document type as necessary.
4) Click OK to save your changes.
Notes

If the option “Warn when not saving in OpenDocument or default format” is checked
on the Options – Load/Save – General dialog (Figure 4), a warning dialog about
potential loss of formatting may be displayed. In most cases, no loss of formatting
will occur, so you may find this warning annoying and choose to disable it.
The Java Runtime Environment is required to use the mobile device filters for
AportisDoc (Palm), Pocket Word and Pocket Excel.
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Export to PDF and XHTML
Each application has the ability to directly export to PDF (Portable Document Format). This
industry-standard format for universal file compression and viewing is ideal for sending the
file to anyone else to view using Acrobat Reader or any other PDF display program on any
operating system.
You can export directly to PDF using the button on the toolbar next to the Printer icon, or by
choosing File > Export as PDF, which allows you to select some detailed options.
To export as XHTML, use File > Export and for File format choose XHTML In the
dropdown box.

Saving files in other formats
To save files in different formats, use File > Save As and select a format from the File Type
dropdown box (Figure 2).

Figure 2. The OpenOffice.org Save As dialog, showing some of the Save formats
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Writer can save to these file formats
In addition to its native formats, Writer can save in these formats:
OpenOffice.org Writer 1.x (.sxw, .stw)
Microsoft Word 97/2000/XP (.doc)
Microsoft Word 95 (.doc)
Microsoft Word 6.0 (.doc)
Microsoft Word 2003 XML (.xml)
Microsoft Pocket Word (.psw)
DocBook (.xml)
Aportis Doc (Palm) (.pdb)
Rich Text Format (.rtf)
Note

StarWriter 5.0 (.sdw)
StarWriter Template (.vor)
StarWriter 4.0 (.sdw)
StarWriter 4.0 Template (.vor)
StarWriter 3.0 (.sdw)
StarWriter Template 3.0 (.vor)
Text (.txt)
Text Encoded (.txt)
HTML (.html; .htm)

The .rtf format is commonly used for transferring text files between applications,
but you are likely to experience loss of formatting and images when the file is
opened by Microsoft Office. The best way to pass a file in Writer to a Microsoft
Word user is to save it as Microsoft Word 97/2000/XP (.doc).

Calc can save to these file formats
In addition to its native formats, Calc can save in these formats:
OpenOffice.org Calc 1.x (.sxc, .stc)
Microsoft Excel 97/2000/XP (.xls; .xlw)
Microsoft Excel 97/2000/XP Template (.xlt)
Microsoft Excel 95 (.xls; .xlw)
Microsoft Pocket Excel (.pxl)
Microsoft Excel 2003 XML (.xml)

Data Interchange Format (.dif)
dBase (.dbf)
SYLK (.slk)
Text CSV (.csv; .txt)
StarCalc formats (.sdc, .vor)
HTM and HTML files

Impress can save to these file formats
In addition to its native formats, Impress can save in these formats:
Microsoft PowerPoint 97/2000/XP (.ppt; .pps)
Microsoft PowerPoint 97/2000/XP Template (.pot)
StarDraw, StarImpress (.sda, .sdd, .vor)
Impress can also export to MacroMedia Flash (.swf) and any of the graphics formats as listed
below for Draw.
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Draw can save to these file formats
Draw can only save in its native and StarDraw formats, but it can export to:
BMP
EMF
EPS
GIF
JPEG

MET
PBM
PCT
PGM
PNG

PPM
RAS
SVG
SVM
TIFF

WMF
XPM

The HTML writer can save in these formats
HTML Document (.html; .htm)
OpenOffice.org 1.0 HTML Template (.stw)
OpenOffice.org 2.0 HTML Template (.oth)
StarWriter/Web 5.0 and 4.0 (.vor)
Text (OpenOffice.org Writer/Web) (.txt)
Text Encoded (OpenOffice.org Writer/Web) (.txt)

Object Linking and Embedding (OLE)
To change the settings for Microsoft Office OLE objects, use Tools > Options > Load/Save
> Microsoft Office (Figure 3).
Having all of these options checked allows embedded objects to be converted and thus be
editable in both office suites.
For other OLE objects, it will depend on the machine where the file is being edited just as it
does with Microsoft Office alone. Thus Windows application based OLE objects will not be
editable in OpenOffice.org on a Linux machine, although the object will still be displayed
correctly and can be resized.

22

Chapter 2 Sharing Files with Microsoft Office Users

Object Linking and Embedding (OLE)

Figure 3. Choosing Load/Save VBA Properties

Linked files
Cells copied from Excel and pasted special, linked and with RTF format, into Word are
imported into Writer as a normal table. This means that when the document is imported, the
link to the Excel file is lost.
Similarly when a chart is copied from Excel and pasted special, linked into Word, and then
the file imported into Writer, the chart is imported as an embedded OLE object but is not
converted into a Calc chart. On saving the file in Word format and then opening the file in
Word and trying to edit the chart by double-clicking, it displays an error message.
Caution

Links in Microsoft Office files between Word and Excel are lost when the
Microsoft office files have been edited by OpenOffice.org.

WordArt and Fontwork
The equivalent to Microsoft Office’s WordArt in OpenOffice.org is Fontwork. WordArt
objects are imported as Fontwork objects; they may look slightly different on import.
Fontwork objects are automatically exported to WordArt objects when the document is saved
in a Microsoft Office format.
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Vector graphics

Vector graphics
The basic shapes (lines, arrows, rectangles, ovals) all import and export without any problem.
OpenOffice.org provides a greater degree of control over some properties than Microsoft
Office does, so sometimes there will be changes when going from OpenOffice.org to
Microsoft Office. Examples include the size of arrow heads, and line styles.
The Microsoft Office autoshapes, such as the smiley face, keep their special characteristics,
for instance the ability to adjust the degree of the smile or frown on the smiley face.
Microsoft Office provides more shadow options than OpenOffice.org, so sometimes there
will be a change in shadow appearance. Microsoft Office shadow styles 1, 2, 4, 6, 14, 17 and
18 are supported in OpenOffice.org. Horizontal and tapered shadows do not get imported and
any 3D effect on the bottom left is ignored.

Frames and text boxes
When frames or text boxes from Microsoft Office are imported into OpenOffice.org with
linked text, the links are lost.

Active content controls
These are the controls in Microsoft Office available on the Controls toolbar; they all import
without a problem. However, as these controls typically require macros to be of use, they will
be functionally useless in the absence of macros custom built for use in OpenOffice.org.

Macros
OpenOffice.org cannot run Microsoft Office macros. Although the macro language is very
similar, the underlying objects are quite different. To set whether OpenOffice.org keeps
attached macros (so that they are still available for use in Microsoft Office) for Word, Excel
and PowerPoint files, use Tools > Options > Load/Save > VBA Properties.
Note

Opening a Microsoft Office file infected with a macro virus is quite safe in
OpenOffice.org.

OpenOffice.org has the ability to record macros. It is better practice to use the application
program interface (API).
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Import, export and sharing issues in text
documents
Good practice in text documents
Some issues can be avoided simply by using good word-processing practice:
•

Use character and paragraph styles rather than direct formatting.

•

Use paragraph formatting for space before and after rather than hard returns,
particularly in numbered or bulleted lists.

•

Use paragraph text flow properties (for example, keep with next) rather than using
manual page breaks.

•

Do not use multiple tabs or spaces to align text – either set specific tab stops or better
yet use a table.

•

Use only commonly available fonts.

Compatibility settings in OpenOffice.org for the
current document
The following settings change the way OpenOffice.org works with the current document so
that it works more like Microsoft Office.
Use Tools > Options > OpenOffice.org Writer > Compatibility (Figure 4).

Figure 4. Choosing compatibility options
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Add paragraph and table spacing at tops of pages (in current
document)

In Writer, with this setting unchecked, if a paragraph at the top of the page (or column) is
formatted with space above then that space is ignored; whereas in Word the space above is
included. Checking this option causes Writer to behave in the same way as Word.
Use OpenOffice.org 1.1 tabstop formatting

This setting specifies whether centered and right-aligned paragraphs containing tabs are
formatted as a whole in the center or aligned to the right. If this checkbox is checked, only the
text to the right of the last tab is aligned to the right, while the text to the left remains as is.
Use OpenOffice.org 1.1 line spacing

Writer uses the greater of the two spacings for above and below paragraphs; Word sums the
two together. Uncheck this box to have Writer behave in the same way as Word.

Font and font spacing
Text effect animations are imported by Writer with the character attribute of blinking from
Word files. For example “Marching red ants” simply becomes “blinking”.
Typically Word’s character spacing is tighter than Writer’s, so often Word will fit more
characters to a line. It is also possible that the spacing between lines could be slightly
different. The end result is that the page breaks may be in different places.

Tables
The author could find no issues with tables.

Mail merge documents
As OpenOffice.org has a different approach to data sources. On importing a Word document
that is the main document for a mail merge, there is no connection with the data source. It is
not just a matter of making that connection; each field needs to be reinserted. See the Mail
Merge section in the chapter titled “Differences in use between Writer and Word”.
Also in Word you can have another Word document as a data source for a mail merge. There
is no way of specifying a Word (or Writer) document as a data source in OpenOffice.org.
Writer does not have the option of suppressing blank lines when data fields are empty, so you
need to use conditional fields.
Writer merge fields export as text with the name of the field between angle brackets, for
example <Name>.
Summary: To work in a shared environment would require a separate file for each “main
document”: one in Word format, the other in OpenOffice.org format. If you have a master
mail merge document in Word format, it is probably easiest to paste the text into Writer and
use the Writer mail merge wizard to recreate the mail merge from scratch.
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Forms
Issues with forms created in Microsoft Office

A locked file in Microsoft Office imports unlocked into OpenOffice.org; that is, in design
mode.
Text form fields import into OpenOffice.org as Input fields and so lose their type. For
example, a text form field of type “number” or “date” will accept any text for input. In use a
text form field in OpenOffice.org displays a dialog for entering the text. Exporting back to
Microsoft Office, text form fields are changed into “Fillin” fields. The current date and time
and calculation fields import as simple text.
Checkboxes import and export correctly.
Drop-down form fields import as Input List fields. Like text form fields in operation these
display a dialog from which the user can select an option. On export back to Microsoft Office
they return to drop-down form fields again.
Issues with forms created in OpenOffice.org

The controls are exported as active controls when there is a Microsoft Office equivalent. As
Word does not have the same database functionality of OpenOffice.org and as the macros are
not compatible, it would be very difficult to have one form that works in both environments
using standard form controls.
Summary: To work in a shared environment with forms is not easy, but one workaround
would be to use other fields like Input field and Input List. To insert these fields, use Insert >
Fields > Other > Functions.

Footnotes, endnotes, tables of contents and indexes
Footnotes, endnotes and indexes all import / export correctly. Some issues have been found:
•

The location of the endnotes may change (in Word the endnotes are placed before the
index. In Writer they are always at the end of the document).

•

Writer bibliographic entries become text in Word.

•

A three-column index exported from Writer to Word as three columns but on re-import
it was one column.

•

On importing a Word file containing index entry fields, the index entry fields are
imported but as fields to the left of the text rather than the field containing the text.

Summary: Working in a shared environment is possible with some minor issues.

Chapter 2 Sharing Files with Microsoft Office Users

27

Import, export and sharing issues in text documents

Numbered paragraphs, outline numbering, crossreferences
Numbered paragraphs, outline numbering, and cross-references import / export without a
problem, except for references to numbered paragraphs:
•

Cross-references to the numbers of numbered paragraphs that are not numbered using
outline numbering do not work as Writer does not have this ability.

•

Writer also does not have the ability to use relative numbering in its cross-references
to numbers.

•

Cross-references to chapter numbers do not have the same format as that displayed.

Page numbering
A quick and dirty approach in Word for having a different first page (like a cover page) and
then to have the numbering start on the second page but numbered as page 1 is to have a
layout of different first page and setting the starting page to be zero. Unfortunately, on
importing such a file into OpenOffice.org the page number on the second page is 2 instead of
1. To fix this problem in Writer:
1) Create a page style for how the pages after the first page should look. Name it (for
example) Convert1.
2) Have the cursor in the first paragraph of the second page.
3) Format > Paragraph > Text Flow.
4) In the Breaks portion of the dialog, select the checkbox Insert.
5) Check With Page Style.
6) Choose the page style created in step 1.
7) Leave the position as Before and set the page number to 1.
On exporting this document back to Word it will work, the only difference being that the
document will have a section break at the end of the first page. Documents created with
section breaks like this in Word will work fine importing and exporting with Writer. There is
one difference with Word: now there will be a blank page between the cover page and the
next page when printed (or print previewed).
In the author’s testing a document with different formats for odd and even page numbering,
the odd page numbers were imported as the text of the first odd page rather than as a field.
Summary: For some documents a little work maybe required to fix up the page numbering on
importing to Writer. Once “fixed” the page numbering of the documents will import / export
without a problem.
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Date and time fields
Word’s CreateDate and SaveDate fields do not get imported with the same formats. For
example, if the fields in the Word document have a format that includes time, then this
information is not displayed by default. To include time in the format:
Right-click on the field > Fields > scroll to the bottom of the Formats listbox > Additional
formats > in format code add HH:MM:SS
On export the SaveDate / DocInformation:Modified is exported as text.
Writer’s Time Fixed and Date Fixed fields get exported as text.

Importing Word fields
Table 2. Imported Word fields conversion

Word field:

Writer converts to:

ASK

Input field

AUTHOR

DocInformation:Created

AUTONUM

Number Range AutoNr

AUTONUMLGL

Number range AutoNr

AUTONUMOUT

Number range AutoNr

COMMENTS

DocInfomation:Comments

CREATEDATE

DocInformation:Created

DATE

Date

EDITTIME

DocInformation:Modified

FILENAME

File name

FILLIN

Input field

HYPERLINK

(as a hyperlink)

INFO xxx

DocInformation:xxx

KEYWORDS

DocInformation:Keywords

LASTSAVEDBY

DocInformation:Modified

MACROBUTTON

(the name of the macro?)

MERGEFIELD

Mail merge fields (displayed as the name of the
field)

MERGEREC

Record number

NEXT

Next record

NOTEREF

Show variable

NUMCHARS

Statistics (with select = Characters)

NUMPAGES

Statistics (with select = Pages)
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Word field:

Writer converts to:

PAGE

Page numbers

PAGEREF

Bookmarks (displayed as name of bookmark)

REVNUM

DocInformation:Document number

SAVEDATE

DocInformation:Modified

SEQ

Number range

SET

Set variable

SUBJECT

DocInformation:Subject

TEMPLATE

Templates

TIME

Date

TITLE

DocInformation:Title

TOC

(Displays the table of contents)

The following fields are not imported into OpenOffice.org (only the text that they displayed
when last saved): =, IF, DOCPROPERTY, FILESIZE, LINK, LISTNUM, QUOTE,
SECTION, SECTIONPAGES, STYLEREF, TOA, USERADDRESS, USERINITIALS,
USERNAME.
The following fields are ignored on import: AUTOTEXT, AUTOTEXTLIST, BARCODE,
BIDIOUTLINE, DOCVARIABLE, EQ, GOTOBUTTON, INCLUDETEXT, LISTNUM,
MERGESEQ, PRINT, RD, SKIPIF, SYMBOL, TA, TC.
The Word field EDITTIME is mapped to Writer field DocInformation:Modified on import
but the meaning has changed to the date and time last saved rather than how long the file has
been open for editing.

Import, export and sharing issues in
spreadsheets
Form fields
Combo boxes, list boxes and checkboxes with links to spreadsheet cells all import and export
properly, although due to font handling the number of rows displayed in list boxes may be
slightly different. List boxes in Calc can either have multi-selection or not, whereas Excel has
two multi-selection modes: multi and extend. In Excel a link from a multi-selection listbox to
a cell is ignored (at least in Excel 2000; the author has not checked Excel XP). In Calc the
link works, but if more than one item is selected, the cell’s value is set to #N/A.
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Option buttons import into Calc, but the link with cells works differently. In Calc each option
button has its own link to a cell, setting its value to true or false depending on whether the
option is selected. In Excel the cell link returns the number of the selected option button. On
exporting option buttons to Excel, the option buttons lose their radio operation; in other
words, they are not grouped so that selecting one “unselects” the others.
Scroll bars and spinners are now implemented in Calc, but are not imported yet.

Array constants
Array constants are not available in OpenOffice.org. The workaround is to have the constant
values in cells on a sheet and refer to them. Array constants used as parameters to a function
in Excel are omitted when imported into Calc.

Optional parameters in formulas
Some formulas have more than one optional parameter at the end of the parameter list. In
Excel it is possible to leave an optional parameter blank and specify a later parameter, but
this is not possible in Calc. Formulas with optional parameters are not correctly imported into
Calc.

Functions
Statistical, engineering and financial functions

In Excel some of the financial functions accept string parameters for dates; in OpenOffice.org
they require a serial number, and thus they are not correctly imported into Calc.
Analysis ToolPak Functions

The function EFFECT provided by the Analysis ToolPak for Excel is converted to
EFFECT_ADD in Calc and returns the same results.
Other functions not implemented / imported

Only three other functions are not imported: INFO, GETPIVOTDATA, and HYPERLINK.
Hyperlinks are supported but not as a function; use the Hyperlink button on the Function bar.

DataPilot—Pivot Table
DataPilots are Calc’s equivalent to Excel’s Pivot Tables. However there are a number of
limitations. Pivot tables import from Excel into Calc (although the cells do not have the
PivotTable shading) but as soon as they are worked on these limitations become apparent.
The limitations are:
•

There is no PivotChart facility, but a DataPilot can be used as the data source for a
chart.
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•

The user interface allows a maximum of 8 fields in the data, row or column areas. (An
alternative interface which allows more is available from:
http://homepages.paradise.net.nz/hillview/OOo/ in a document called
MyDataPilot.sxc.

•

There is some ability to group data (for example, a date field grouping by week or
quarter but not by month). The workaround is to create a new column with a formula
for calculating the grouping, e.g. =Month().

•

You can not define different formats for different fields.

•

Calc can have formulas based on things like “Difference From” or “% of”, but can not
have own custom fields (work around create new columns to calculate the desired
values).

•

The Application Program Interface specification is incomplete for writing macros that
work with DataPilots—for example, the ability to control through another program,
such as OpenOffice.org’s own macro language, BASIC, whether the tables have grand
totals, or having access to DataPilots created from external data.

AutoFilter
AutoFilter imports and exports correctly with the required rows being hidden. However, there
are a number of differences between Excel and Calc:
•

There is only one AutoFilter active for a spreadsheet document at a time. The rows
remain hidden but the drop-downs in the first row disappear on applying AutoFilter
elsewhere.

•

The remaining visible row numbers do not change color to warn that there is a filter in
place.

•

Error values do not show as an option in the drop down lists when cells in the column
have errors.

•

In the drop down lists, the equivalent to Excel’s “Custom” is called “Standard”.

Charts
Chart types that Excel provides but Calc does not:
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•

Bar of pie converts to a 2D – columns – normal.

•

Pie of pie converts to a 2D – columns – normal.

•

Radar filled converts to 3D – columns deep.

•

Radar with markers – converts to 2D – net – normal but counterclockwise rather than
Excel’s clockwise.
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Other charting issues include:
•

There are fewer axis options, such as no option for having an inverted y axis (negative
at top towards positive at bottom).

•

The data must be contiguous, with the labels in the first row or column.

Number formats
There is no “accounting” format (with the currency symbol at the left edge of the cell). A
workaround would be to have another column to the left that contains the currency symbol.
There is no predefined option for bracketing negative numbers. Use a custom format such as
“$#,##0.00_);[RED]($#,##0.00)”.

Grid lines
In Excel grid lines are a property of a worksheet; in Calc it is an application-wide option:
Tools > Options > OpenOffice.org Calc > View

Import, export and sharing issues in
presentations
Color gradients and borders
The author had not noticed the following changes, so this is a direct quote from StarOffice 7
Migration Guide by Sun.
Unlike Microsoft PowerPoint, StarOffice Impress does not support three-color gradients,
double and triple borders, or round-dotted borders. To improve the results of the import, you
have to make the necessary adjusts before import. Change three-color presets to similar twocolor gradient fills and change double and triple border lines to a single border line with
appropriate width. Round-dotted border lines that are mapped to rectangle-border closely
resemble the original line style in PowerPoint, so manual editing should not be necessary.

Multimedia
Voice-over narration is not supported by Impress.
There appear to be no settings for multimedia custom animations, such as the ability to play a
sound for the next slides.
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Chart animations
There is no facility in Impress for “chart effects” as there is in PowerPoint, such as presenting
a series or category at a time. On import the charts simply appear. A workaround is to have
multiple copies of the chart with each one set up to display as desired.

Pack and Go
The Pack and Go feature in PowerPoint allowed a PowerPoint file to be split over several
floppy disks and assured that all related files were included. This facility is not included in
Impress, nor can Impress open such files.

Fields
Date fields are exported as text, so they do not automatically update.

Action settings and interaction
PowerPoint provides action settings for mouseover, but Impress does not have this option,
only on mouse click, so mouseovers get mapped to mouse clicks. PowerPoint has an option
for highlighting the object on mouse click or mouse over; Impress does not have this, so it
gets ignored on import.

PowerPoint custom animations and Impress object
effects
Table 3 shows how the custom animations and object effects are imported into Impress and
exported to PowerPoint.
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Table 3. Importing / exporting custom animations between PowerPoint and Impress

PowerPoint

Impress

Appear

Appear

Blinds

Fade Horizontally

Box

Fade To Center

Checkerboard

Checkerboard

Diamond

Appear

Crawl

Fly In From bottom

Dissolve

Dissolve

Flash once

Appear

Peek

Short Fly In from Bottom

Random Bars

Horizontal lines

Spiral

Spiral Outward Clockwise

Split

Close Vertical

Stretch

Stretch Vertical

Strips

Fade From Top Right

Swivel

Rotate Horizontally

Wipe

Cross-Fade From Top

Zoom

Fade From Center

Random effects

Vertical Lines

PowerPoint—Impress slide transitions
Table 4 shows how slide transitions are imported into Impress and exported to PowerPoint.
Table 4. Importing / exporting slide transitions between PowerPoint and Impress

PowerPoint

Impress

Blinds Horizontal

Venitian Blinds Horizontal

Blinds Vertical

Venitian Blinds Vertical

Box In

Box In

Box Out

Box Out

Checkerboard Across

Checkerboard Across

Checkerboard Down

Checkerboard Down

Cover Down

Cover Down

Cover Left

Cover Left

Cover Right

Cover Right
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PowerPoint
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Impress

Cover Up

Cover Up

Cover Left Down

Cover Left-Down

Cover Right Down

Cover Right-Down

Cover Left Up

Cover Left-Up

Cover Right Up

Cover Right-Up

Cut

No effect

Cut Through Black

No effect

Dissolve

Dissolve

Fade Through Black

Fade Through Black

Random Bars Horizontally

Random Bars Horizontal

Random Bars Vertically

Random Bars Vertical

Horizontal In

Split Horizontal In

Horizontal Out

Split Horizontal Out

Split Vertical In

Split Vertical In

Split Vertical Out

Split Vertical Out

Strips Left Down

Fade From Top Right

Strips Left Up

Fade From Bottom Right

Strips Right Down

Fade From Top Left

Strips Right Up

Fade From Bottom Left

Uncover Down

Uncover Down

Uncover Left

Uncover Left

Uncover Right

Uncover Right

Uncover Up

Uncover Up

Uncover Left Down

Uncover Left-Down

Uncover Left Up

Uncover Left-Up

Uncover Right Down

Uncover Right-Down

Uncover Right Up

Uncover Right-Up

Wipe Down

Wipe Down

Wipe Left

Wipe Left

Wipe Right

Wipe Right

Wipe Up

Wipe Up

Random Transition

Random Transition
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Introduction
This chapter describes how to import custom dictionaries and AutoText entries from
Microsoft Office to OpenOffice.org. The author knows no easy way of importing Microsoft
Office AutoCorrect entries into OpenOffice.org.

Custom dictionaries
Dictionaries are used when checking any document for spelling errors. Custom dictionaries
are enhanced dictionaries that contain words applicable to particular industries or pursuits,
unique words, or custom spellings.
OpenOffice.org does not provide a way to import Microsoft Office’s custom dictionaries.
However, a macro has been developed to import Office’s custom dictionaries into
OpenOffice.org. A link to download the file is at http://ooomacros.org/user.php#114694.
To import Microsoft Office’s custom dictionaries, follow the steps below. (Details are given
in the following sections.)
1) Create a new dictionary in OpenOffice.org (optional).
2) Download the file that contains the macro.
3) In Microsoft Word, locate where the custom dictionaries are stored.
4) Import the dictionary into OpenOffice.org.

Create a new dictionary in OpenOffice.org
This step is optional. You can add the words to an existing custom dictionary in OOo.
1) Tools > Options > Language Settings > Writing Aids > New.
2) New Dictionary dialog (Figure 5): Give the dictionary a name.

Figure 5: Creating a new dictionary in OpenOffice.org
3) Choose a language for the dictionary if you want to limit it to that language, or leave it
at [All].
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4) Click OK to save your choice and return to the Writing Aids page.
5) Click OK to close the Options dialog.

Download the file that contains the macro
1) In a web browser start at http://ooomacros.org/user.php#114694 and click on the link
for Download Dictionary Import/Export .
2) This should display a SourceForge page. Click on the latest link for this file.
3) Choose a mirror close to you to increase the file transfer speed.
4) The browser should display a Save File dialog. Fill in the dialog. Remember where
you save the file.
5) Unzip the file that you saved in the previous step. You should now have a file named
ImportExportDictionary1-1.sxw (or a similar name).

In Microsoft Word, locate where the custom
dictionaries are stored
In Word, choose Tools > Options > Spelling & Grammar > Custom Dictionaries button.
Look for the name of the custom dictionary you want to transfer. The default name is
CUSTOM.DIC.
The typical location is: C:\Windows\Application Data\Microsoft\Proof\CUSTOM.DIC but in
shared systems it may be C:\Documents and Settings\Username\Application
Data\Microsoft\Proof\CUSTOM.DIC. A partial path is shown at the bottom of the Custom
Dictionaries dialog in Word.
You can use Windows Explorer to find the file. For CUSTOM.DIC you may need to include
hidden and system files in your search in later versions of Windows.

Import the dictionary into OpenOffice.org
1) Open the file in OpenOffice.org that contains the import/export macro downloaded in
step 2 above.
2) A confirmation dialog about running macros may be displayed. If it is, click Enable
Macros.
3) Click the Run Macro button (towards the top of the document).
4) On the Import & Export Dictionary dialog (Figure 6), in the Text file field, either type
in the location of the custom dictionary to be imported or click on the ... button,
navigate to the custom dictionary, select it and click Open.
5) Choose from the dropdown list the OOo dictionary to which you want to add the
words; this may be the one that you created earlier.
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Figure 6. Choosing an OOo dictionary for words
imported from Microsoft Word
6) Click Import. Two dialogs will be displayed, one after the other. The first dialog says
how many words are in the OOo dictionary to which you are adding the words (if you
have just created the OOo dictionary, this number is probably 0) and the second how
many words the OOo dictionary holds after the import. Click OK to close each of
these dialogs.
7) Click Close in the Import & Export Dictionary dialog.
8) Close the Import/Export Text File document and the job is done.
To check that the OOo custom dictionary contains the words from the Word custom
dictionary, go to Tools > Options > Language Settings > Writing Aids, select the dictionary
to which you added the words, and click Edit. The list of words is displayed in the Edit
Custom Dictionary dialog.

AutoText entries
AutoText is a feature that stores formatted text or text with graphics, tables and fields and
provides the means to easily insert the saved material into documents.
OpenOffice.org stores AutoText entries in XML files in specified folders. Microsoft Word
stores AutoText entries in template files, mainly in Normal.dot. To import the AutoText
entries from the Word templates follow these steps:
1) Locate the Word template from which you want to import AutoText. Typically
templates are found in:
C:\Windows\Application Data\Microsoft\Templates or
C:\Documents and Settings\Usersname\Application Data\Microsoft\Templates.
2) In OOo, select Edit > AutoText (or press Control+F3).
3) You can create a new category or use one of the standard categories.
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To create a new category:
1) On the AutoText dialog (Figure 7), click the Categories button.

Figure 7: Creating a new AutoText category
2) On the Edit Categories dialog, type a name for the new category, choose the path to
where you want it saved, and click New. The new category now appears in the
Selection list in the middle of the dialog.
3) Click OK. to close the Edit Categories dialog and return to the AutoText dialog.
To import the AutoText:
1) On the AutoText dialog, select the category into which you will import the AutoText
entries. Click AutoText > Import.
2) In the Open dialog, navigate to and select the desired Word template and click Open.
The AutoText entries should now be visible in the left list box of the AutoText dialog.
3) Click Close.

AutoCorrect entries
AutoCorrect is a feature to automatically correct words as you type. You can add entries to
the AutoCorrect function to customize the way that OpenOffice.org operates.
The author has not been able to find a way of importing Microsoft Office AutoCorrect entries
into OpenOffice.org. A thread discussing this problem can be viewed at:
http://www.oooforum.org/forum/viewtopic.php?t=10248.
Information from that thread is copied below, because it is reportedly possible for you to
import the “first hundred or so” entries using this information.
There is a Word macro available from
http://word.mvps.org/FAQs/Customization/ExportAutocorrect.htm for creating a Word
document with the AutoCorrrect entries.
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OOo AutoCorrect files are typically stored in ./user/autocorr/acorrXXXX.dat (where XXXX
corresponds to the number for a given locale).
TIP

You can get a list of locale numbers from Microsoft Office Online:
http://office.microsoft.com/en-us/assistance/HP052590231033.aspx

These files are zipped and contain the file DocumentList.xml (if no AutoCorrect entries have
been created the file will be empty) which looks like:
<block-list:block-list>
<block-list:block block-list:abbreviated-name="(C)" block-list:name="©"/>
<block-list:block block-list:abbreviated-name="yuor" block-list:name="your"/>
</block-list:block-list>
So it would not be too difficult to create a text file to look like this and to zip it into a
acorrXXXX.dat file.
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Help

Help
The Help facilities in OpenOffice.org (OOo) are very similar to the equivalent in Microsoft
Office (MSO).
If you pause the mouse pointer over a button, you will see a tooltip describing the button. To
turn this feature on or off, use Tools > Options > OpenOffice.org > General.
Pressing Shift + F1, selecting Help > What’s This?, or clicking
changes the pointer to a
question mark. When the question mark pointer is over a button or control on a dialog, a
more detailed description is displayed until the next mouse click.
Note

Pressing Shift + F1 is equivalent to turning on extended tips, Tools > Options >
OpenOffice.org > General, except that it only stays on until you click again.

Based on whatever is currently selected, pressing F1 displays contextual help.
The equivalent to the MSO “Office Assistant” is called the Help Agent. It
“lights up”, alerting the user that help is available for an event that has just
happened. Examples are when a user first saves a file, or when a word gets
automatically corrected.
The Help Agent can be turned off and on by using Tools > Options >
OpenOffice.org > General.

Zoom - the view percentage
To change the size at which the document is displayed on the monitor, select View > Zoom,
or right-click or double-click the number with a percentage sign next to it on the status bar.
In Writer the Optimal option zooms the display so that the document is displayed between
left and right margins. The zoom factor is automatically adjusted when side panels are
displayed.

AutoCorrect and AutoFormat
AutoCorrect and AutoFormat work much the same in OOo as in MSO.
In addition, Writer includes a word completion feature. If it is enabled, Writer tries to guess
which word you are typing and offers to complete this word for you. To accept the
suggestion, press Enter. Otherwise continue typing.
Settings for this feature, including turning it off or changing the key that accepts the
suggestion, are in the Tools > AutoCorrect > Word Completion tab (Figure 8).
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Figure 8: Settings for automatic word completion

Menus
OOo’s menus are similar to MSO’s, but some commands are in different locations. For
example, OOo considers page layout a format issue, so it is found in the Format menu
(Format > Page) instead of in the File menu. In addition, OOo includes some features that
MSO does not (for example, built-in Export to PDF).
For information on how to customize menus (including adding and removing items), see
Chapter 8, “Customizing OpenOffice.org” in this guide.

Personalized menus
OOo does not have personalized menus. This feature in MSO reorganizes the menus so that
your most frequently used options are displayed first and little-used options are removed
from the list.
In OOo some menu items may be relevant to the current cursor location but are inactive and
grayed-out. For example, the sort command (Tools > Sort) is not available when nothing is
selected. By default these menu items are not displayed. To make them visible, use Tools >
Options > OpenOffice.org > View > Show inactive menu items.
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Toolbars
The default location of some icons may be different from the default location in MSO. The
icons are also not identical. Many icons can be expanded into submenus or tear-off toolbars.
Most toolbars in OOo can be made floating or can be docked in various positions. To move a
toolbar, place the mouse pointer over the toolbar handle (or the title bar of a floating toolbar),
hold down the left mouse button and drag the toolbar to the new location.
Tear-off toolbars area always floating. See Chapter 4, “Menus and Toolbars” in the Getting
Started guide for more information on moving, docking and customizing toolbars.
For information on how to customize toolbars (including adding and removing icons), see
Chapter 8, “Customizing OpenOffice.org” in this guide.

Drag and drop
While drag and drop does work in OOo, there is less feedback with pointer changing in OOo
than in MSO. For example, when moving the pointer onto a selected piece of text, the pointer
remains the usual I bar rather than changing to an arrow. However, the text can be dragged as
required.
There is no equivalent to Shift+Click+drag.

Side panes - docked or floating windows
MSO XP introduced the concept of side panes. These are the closest equivalent to OOo’s
docked or floating windows. In OOo these windows include:
•

Navigator to help move around the document (the closest equivalent in MSO would be
the Outline view in Word).

•

Styles and Formatting for managing styles.

•

Gallery, a clip art viewer.

•

Function Wizard, which helps you interactively create formulas; available only in Calc.

•

Data Source Explorer, from which you can drag and drop fields from registered
databases into your documents; available in Calc and Writer.

There is no equivalent of the MSO Clipboard for handling multiple copies.
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Docking and undocking
Some windows in OpenOffice.org, such as the Navigator and the Styles and Formatting
window, are dockable. You can move, re-size or dock them to an edge.
To dock a window, do one of the following:
•

Click on the title bar of the floating window and
drag it to the side until you see the outline of a
box appear in the main window (see Figure 9),
then release the window. This method depends
on your system’s window manager settings, so
it may not work for you.

•

Hold down the Control key and double-click on
a vacant part of the floating window to dock it
in its last position. If that does not work, try
double-clicking without using the Control key.

To undock a window, hold down the Control key and
double-click on a vacant part of the docked window.
Note

The Styles and Formatting window can also
be docked or undocked by using Control+
double-click on the gray area next to the
icons at the top of the window.

Figure 9: Docking a window

It is possible to have two windows in the same area. For example, the Styles and Formatting
window and the Navigator can be at the right edge with one above the other rather than side
by side. Then the show/hide and stick/floating buttons work for both docked windows.

Resizing
Docked windows can be resized by moving the border. When the mouse pointer changes to a
double-ended arrow, click and drag the window to the desired size.

Navigator
The Navigator (Figure 10) is activated and deactivated by F5, the Navigator button, , in
the Standard toolbar, or Edit > Navigator. This window shows the different objects in the
current document and enables you to move quickly among them. Details vary from one
application to another. For example in Writer it shows the list of headings and has controls
similar to Outline view in Word. The drop-down list at the bottom of the Navigator is for
selecting which of the currently open documents has information displayed in the Navigator.
For more information, see “Using the Navigator” in Chapter 4, “Menus and Toolbars” in the
Getting Started guide, and descriptions of the Navigator in the guides for each of the
applications.
Chapter 4 General Differences in Use between OpenOffice.org and Microsoft Office
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Figure 10. The Navigator in Writer

Styles and Formatting
The Styles and Formatting window (Figure 11) can be activated and deactivated by F11, the
Styles and Formatting icon

, or Format > Styles and Formatting.

Figure 11: Styles and Formatting window in
Writer
To change the category of styles displayed, use the buttons across the top of the window. For
example, in Writer the buttons are Paragraph, Character, Frame, Page, and List. The dropdown list at the bottom of the Styles and Formatting window determines which of the style
types get displayed in the window. For example, in Writer for character styles the options are
Hierarchical, All, Applied, and Custom.
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The style of the current selection is highlighted in the list of styles.
See Chapter 6 “Introduction to Styles” and Chapter 7 “Working with Styles” in the Writer
Guide for more information about style types and how the other icons in the window work.

Gallery
The Gallery (Figure 12) is activated and deactivated by clicking the Gallery button
the Standard toolbar or by selecting Tools > Gallery.
Note

, in

There is no default shortcut key to activate the Gallery.

Figure 12: The Gallery in Writer
The Gallery is OOo’s equivalent to MSO’s Media Gallery, except that it does not have ties to
the Web and there is no search facility. In order to keep the OOo download as small as
possible, very little clip-art comes with OOo. To download some public domain clip-art, see
http://www.openclipart.org/.
Media in the Gallery is organized by themes. Themes are displayed down the left side of the
Gallery window.
For information on how to use the Gallery, see Chapter 14 “Working with the Gallery” in the
Getting Started guide.
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Data Source Explorer
The Data Source Explorer is activated and deactivated by pressing F4 or by clicking the Data
Sources button

in the Standard Toolbar or by selecting View > Data Sources.

Figure 13: The Data Source Explorer in Writer
A common use for this window is in setting up a template for a mail merge letter. You can
drag and drop fields from data sources in the Explorer to create fields in the current
document.
The Data Source Explorer can only be docked at the top of the main window.
For more information on how to use data sources, see Chapter 10 “Getting Started with Base”
in the Getting Started guide.

Page preview
File > Page Preview in OOo is the equivalent of MSO’s Print Preview. You can chose to
view and print single pages, two pages, multiple pages, or facing pages (called “Book
Preview”).
The Zoom button in OOo only zooms the view. It does not provide a pointer for you to select
an area to zoom in on.
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Keyboard shortcuts
These standard keyboard shortcuts are the same as in MSO:
•

Cut (Control+X)

•

Copy (Control+C)

•

Paste (Control+V)

•

Undo (Control+Z)

•

Redo (Control+Y)

•

Save (Control+S)

•

Open (Control+O)

•

New (Control+N)

Smart tags
Smart tags are not available in OOo.

Special characters or symbols
The equivalent of insert symbols is Insert > Special Character.
You can not enter special characters in OOo using standard hex codes as you can in MSO.
Note

There is no second tab for common special characters such as the em-dash.
Workarounds are to use AutoFormat/AutoCorrect, AutoText or you can record a
macro.

File management
Default locations
Use Tools > Options > OpenOffice.org > Paths to set the default locations for file storage.
The two path settings of interest (at this stage) are My Documents and Templates.
My Documents only allows one location. It is not possible to have a separate folder for each
of the applications. This folder is the default location for File > Save As and is the folder that
gets displayed in the OOo Open and Save As dialogs.
For templates it is possible to have more than one folder specified. These are the folders that
are shown down the left side of the dialog that gets displayed for File > New > Templates
and Documents (see “Creating new files” on page 52).
Chapter 4 General Differences in Use between OpenOffice.org and Microsoft Office

51

File management

For more about defining default locations, see Chapter 5 “Setting Up OpenOffice.org” in the
Getting Started guide.

Creating new files
In OOo, as with MSO, there are a number of different ways of creating new files. What is
different is that you can initiate the creation of any OOo file type from any OOo application.
For example, you can start creating a spreadsheet while working in Writer.
Different ways of creating a new document:
•

Select File > New.

•

Use the New icon on the Function Bar. This icon has a drop-down list on the right to
select the type of document to be created.

•

From a “Quick start” program. Only the Windows version of OOo has a Quickstart
icon in the system tray.

•

Press Control+N.

•

Using Wizards: select File > Wizards.

Template folder management
To make it easier to manage your templates, such as creating and deleting folders
(categories), and importing templates into the folders, use:
File > Templates > Organize > Double-click the desired folder > Commands

Default templates
Each component of OOo has a unique default template. To change the default template for a
component:
1) Save the current template using File > Templates > Save.
2) Select File > Templates > Organize,
3) Double-click the folder in which you saved the template in step 1.
4) Click on the template you want to make the default.
5) Either right-click or select Commands > Set As Default Template.
Note
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The default template in MSO is always a file called Normal.dot. In OOo there is no
special name for the default template files. They can be called anything. If no
template has been specified, the properties of the default template are those that are
coded directly into OOo.
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Open and Save As dialogs
Under Microsoft Windows there is the option to use either the OOo Open and Save As
dialogs or the ones provided by Windows. To view or change which type of dialog OOo is
using, select Tools > Options > OpenOffice.org > General > Use OpenOffice.org dialogs.
Note

The dialogs provided by Windows are not the dialogs used by MSO!

This section discusses the OpenOffice.org Open and Save As dialogs. See Figure 13 for an
examples of the Open dialog; the Save As dialog is similar.
The three buttons in the top right are, from left to right:
•

Go Up one level in the folder (directory) hierarchy. This is a long-click button if you
want to go up higher than just one level

•

Create New Directory (folder).

•

Go to the Default Directory as specified in Tools > Options > OpenOffice.org > Paths.

For OOo documents that have been saved as more than one version, you can use the version
drop-down to select the version you want to open in read-only mode.
Note

For Microsoft Office documents, only the current version can be opened.

Figure 14. The OOo Open dialog.
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The File type field has the same concept in OOo as in MSO; use it to specify the type of file
to be opened or the format of the file to be saved.
The Read-only checkbox opens the file for reading and printing only. Consequently most of
the toolbars disappear and most menu options are disabled. An Edit File button is displayed
on the Function Toolbar to open the file for editing. The opened file cannot be saved over the
previous filename.
It is possible to open files from the web using URLs.
File management within an OpenOffice.org Open or Save As dialog

To rename a file:
1) Right-click on a file name to display a context menu.
2) Click Rename and the file name will be selected.
3) Typing replaces all or part of the selected name.
To delete a file:
1) Right-click on a file name to display a context menu.
2) Click Delete and you will get a confirmation dialog.
Note

Instead of Right-click > Delete, you can select the filename and press the Del key.

It is not possible to move files around by copying and pasting them within the dialogs.

Password protection
To protect an entire document from being viewed, there is a checkbox in the Save As dialog
to Save with password. This option is only available for files saved in OOo formats.

Privacy options
To include or remove personal information (for example, the author’s name) in the Properties
dialog with the document, go to File > Properties > General. The Delete button removes
information. The Apply user data checkbox includes or removes information such as
“Author”.

Digital signatures
OOo provides digital signatures to ensure the integrity of the file, as do recent versions of
MSO.
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Portable Document Format (PDF) file creation
All of the applications in OOo have the built-in ability to export documents as PDF files.
Click on the Export Directly as PDF icon on the Standard toolbar,
, or use File > Export
as PDF. The second method provides access to choices that include the print quality and the
range of pages to be printed to the file.

Creating web pages (HTML files) overview
All of the OOo applications can be used to create web pages. This section introduces their
HTML capabilities. For more details, see Chapter 16 “Creating Web Pages” in the Getting
Started guide.
Writer

Writer’s HTML capabilities include saving existing documents in HTML format, creating
new documents as HTML and creating several different types of web pages using a wizard .
Calc

Calc can save its files as HTML documents. If the file contains more than one sheet the
additional sheets will follow one another in the HTML file. Links to each sheet will be placed
at the top of the document. Calc also allows the insertion of links directly into the spreadsheet
by using the Hyperlink dialog.
Draw

It is possible to export drawings as Macromedia Flash files: File >Export and choose
Macromedia Flash for the file type.
The drawing program also allows you to turn your drawings into a series of HTML web
pages.
Impress

Exporting presentations from OOo’s Impress application is similar to exporting a drawing
from Draw. Use File > Export and select HTML document as the file type. The only
difference is that there is an option to display each slide’s notes along with the slide.

Document properties
Some differences in document properties are:
•

Summary (MSO) or Description (OOo): OOo does not include fields for manager or
category.

•

Statistics: Writer includes the word count (also available in Tools > Word Count).

•

Custom (MSO) or User defined (OOo): OOo provides only four fields. To name the
fields as you like, click the Info fields button.

•

Use the Internet tab to set the refresh and redirect options for an HTML page.
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Searching for files
There is no Find Files command built-in to OOo for finding files that contain specific text.
However a component has been written that can be installed to provide this functionality. See
http://qa.openoffice.org/issues/show_bug.cgi?id=41011.

Object linking between files
For information on Object Linking and Embedding (OLE), and what happens with imported
files containing DDE links, see Chapter 2, “Sharing Files with MSO Users” in this guide.
In the Windows version of OOo you can copy and paste-special cells from a Calc spreadsheet
into a Writer document as a Dynamic Data Exchange (DDE) link. In the Windows version
you can create a DDE field. Neither of these options is available in the Linux version.
Opening a file from the Windows version in a Linux version works, although some
modification of the file location may be necessary. If you would like to know more, see
http://www.openoffice.org/issues/show_bug.cgi?id=5317.
Regardless of operating system, it is not possible to have a link to a chart.

AutoRecovery saves
To turn on/off AutoRecovery saving and set the time period between saves, use:
Tools > Options > Load/Save > General > Save AutoRecovery information every
Caution

AutoRecovery saves will not allow you to return to the original version of a
document. AutoRecovery saves save the current document at that instant. If you want
to save a backup copy that you can return to in case you make a mistake, check the
Always create backup copy checkbox in the Load/Save options. This will created a
backup copy every time you click Save. However, it only saves one backup per
filename.

Version control
With version control you can save more than one version of a file under one file name. In
MSO each version contains all of the changes that have been made to the document (like fast
saves). In OOo each version is complete. Use File > Versions.
To save a version of a file, see “Open and Save As dialogs” on page 53.

Working with multiple open files
OpenOffice.org uses a Single Document Interface (SDI). This means that each open
document has its own window. The Window menu displays all of the currently open
documents in OOo.
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Two of OOo’s strong points are the accessibility of information about the active document
and the ease of navigating among open documents. Each OpenOffice.org window provides
menus, toolbars and other features directly relating to the document in that window.
When more than one OpenOffice.org document is open, you can switch between the active
document and other open documents in several ways:
•

From the Window menu, select the document you want to become active.

•

Use the Minimize button on the titlebar to minimize the active document and reveal
other open documents.

•

Select a document from your desktop’s Panel or Taskbar to activate it.

•

Close the current document to access other open documents.

•

Use the Alt+Tab shortcut keys to cycle through the open documents.

In MSO Control+F6 switches between documents. In OOo F6 is used to move to the menu
and each of the toolbars. Control+F6 makes the current document active.

Find and Replace
Find and replace are combined in OOo, unlike MSO. There is no separate menu entry or key
shortcut for replace. Use Edit > Find & Replace, or Control+F , or click the Find & Replace
icon
on the Standard toolbar.

Figure 15: The Find & Replace dialog
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There is no “word forms” search.
Having performed a search, and having closed the dialog box, the keyboard shortcut to repeat
the search is Control+Shift+F.
Searches are paragraph-based. There is no way to search for text either side of a paragraph
marker. For example, OOo cannot search for two blank paragraphs. To get around this
problem, and some other issues, a macro has been developed. See IannzFindReplace (last
updated 20 March 2006), available from http://homepages.paradise.net.nz/hillview/OOo/.
Note

Manual page breaks are handled internally by changing the paragraph format of the
first paragraph on the new page. When searching for formats this option is grayed
out because there is no way to search for “manual” page breaks.

Tips for find and replace
It is common to do several find and replace operations on the same selection, however OOo
does not “remember” the original selection. Before doing the find and replace you can
bookmark the selection in Writer, or define a range name for the selection in Calc, so that, by
using the Navigator, the same range can be quickly reselected.
Doing a “find all” selects all the pieces of text that match the criteria. It is possible to
perform, on all the selections, most operations that are possible on a single selection.

Attributes
The Attributes button is only available in Writer’s Find & Replace dialog. This button
displays a dialog with a series of checkboxes to find where a particular attribute has been
changed from the default for the underlying style. For example, selecting the attribute “Font
weight” will find text that has been made bold where the underlying font is not bold (and vice
versa).
Note

The attributes settings remain between uses of the Find & Replace dialog. This can
be frustrating, so always turn off all of the attribute settings after each use.

Formats
This is the same search concept as in MSO. Note that when formats are used, there is an
option to include searching within styles. For example, searching for bold text would not find
bold text where the style is bold unless this option is checked.
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Regular expressions
“Regular expressions” are significantly different in OOo from MSO’s “Use wildcards”. See
Help > OpenOffice.org help > Index tab > and type in “regular expressions” then move to
“Searching” and press Display. Some common examples are in Table 5. To use regular
expressions, click the More Options button of the Find & Replace dialog and make sure the
Regular expressions checkbox is checked. On reopening the Find & Replace dialog, the
Regular Expressions checkbox is always unchecked.
Table 5. Sample regular expressions

Problem

Search

Replace

Replace multiple tabs with just one tab

\t*

Replace multiple spaces with just one space. “[:space:]”
finds both non-breaking spaces and normal spaces but not
tabs. Type a normal space in the Replace field.

[:space:]*

Remove leading white space (space or tabs in any
combination) at the start of a paragraph.

^([:space:]|
\t)*

Remove trailing white space (space or tabs in any
combination at end of paragraph).

([:space:]|
\t)*$

Find paragraphs beginning with the character “a” (the rest
of the paragraph can vary) and replace the whole paragraph
with a blank line.

^a.*

Remove a paragraph mark from the end of lines. for
example, when having pasted text from an e-mail message.

$

Replace paragraph marks with a comma so that there is one
long line rather than many lines.

$

,

Replace commas with a paragraph mark.

,

\n

Replace line breaks (Shift+Enter) with paragraph markers.
(Note that \n is used for both the Search and Replace
fields. In search it is interpreted as a newline and in replace
as a paragraph mark. There is no ability to have a line
break in the replace field.)

\n

\n

Find the word “the” only (do not find “then” or “bathe”).

\<the\>

Find “ing” at the end of a word, for example reading or
writing but not singer.

ing\>

Find whole words that end with “ing”. Note that there is a
space between the caret and the close-square-bracket
character.

[^ ]*ing\>

Select all numbers at the start of a line where the numbers
could include a period, for example 1.1., 1.13.2 and
4.1.15.9.

^[0-9.]*
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Note

The asterisk “*” means any number of the preceding character. Where in MSO you
might have just “*” the equivalent in OOo is “.*” because “.” stands for any single
character (like MSO’s “?”).

A macro that makes it easier to use regular expressions in Writer, and allows searching for
“page breaks” and for things such as multiple blank paragraphs, is available in a document
called IannzFindReplace.sxw available from http://homepages.paradise.net.nz/hillview/OOo/.

Similarity search
The Similarity search option broadens the search so that what is found does not have to be
exactly the same as what was specified in the Search for field. To specify how different it can
be, select the Similarity search checkbox in the Find & Replace dialog.

Search for styles
Writer and Calc have an option in the Find & Replace dialog: Search for Styles (which
changes to Within Styles if Format or Attribute search is used). Check this first if you are
searching for a particular style. The Search for Styles field changes to a listing of the
paragraph styles in use.

Grammar checking
There is no grammar checking function in OOo. There are, however, a number of grammar
checkers under development:
Language Tool is a Python-based grammar checker originally written for German. Rules
sets for Hungarian and English are also available. More information is available from
http://tkltrans.sourceforge.net/ and from http://www.danielnaber.de/.
An Gramadóir is a Perl-based grammar checker originally written for Irish. More
information is available from http://borel.slu.edu/gramadoir/index.html. [This one is
probably the best suited for languages that use noun classes, or an evidential grammar.]
CoGrOO is a grammar checker for Portuguese that is still in the alpha stage. More
information is available from http://www.pcs.usp.br/cgibin/jkinoshi/cogroo/experimente.cgi
Cymraeg is a grammar checker for Welsh. This is a commercial product. A
demonstration copy of it can be obtained from
http://www.bangor.ac.uk/ar/cb/cymraeg/demo_meddalwedd.php.
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Migration Guide

Chapter 5
Differences in Use between
Writer and Word

Overview

Overview
This chapter summarizes the differences in use between OpenOffice.org Writer 2.0 and
Microsoft Word (various versions). The information in this chapter builds upon the
information given in Chapter 4, “General Differences in Use between OpenOffice.org and
Microsoft Office”.

The Writer interface
The main Writer workspace is shown in Figure 16. The menus and toolbars are similar to
those in Word, with the exceptions described in this chapter.

Figure 16: The main Writer workspace in Print Layout view

Views
Word has 4 or 5 views, depending on the version (here with the 5 views of Word 2003)
called:
Normal: Recommended view (by Microsoft) for doing most of your typing and editing.
Writer has no real equivalent view.
Print Layout: This shows the document (more or less) as it will print. This is the closest
equivalent to the Print Layout view in Writer.
Web Layout: In theory, this shows the document as if viewed on-line. Writer’s equivalent is a
view option called Web Layout. To access this view, select View > Web Layout.
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Reading Layout: Reading Layout view formats your screen to make reading your document
more comfortable. Writer has no real equivalent view, but you can go to View > Zoom to
choose the view that will fit the best for you on your screen.
Outline: For working with heading hierarchies. Outline view displays the document in outline
form. Headings can be displayed without the text. If you move a heading, the accompanying
text moves with it. Writer has the Navigator, which is detailed later in this chapter.
Writer also has an HTML source view that only shows when editing an HTML document. To
access this view, select View > HTML Source.
When field codes are turned on, Writer displays less information about the field than does
Word. To get detailed information, right-click the field > Fields (or select the field > Edit >
Fields).

Status bar
The status bar is similar to Word’s except it does not show the current location of the cursor
on the page (row number and number of characters across). It does however show the
position within a table in spreadsheet style format; for example, Top left cell =A1.

Navigator
Word does not have a similar concept to the Navigator and, in the author’s opinion, it is such
a useful tool it is worth taking the time to learn more about it.
To launch the Navigator (Figure 17), press F5 or click the Navigator icon on the Standard
toolbar.

Figure 17: The Navigator
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To get a detailed description of what each of the buttons does, press Shift+F1 and hover the
cursor over the buttons.
The Headings at the top of the list box in the Navigator are the closest equivalent to Word’s
Outline View.
With the List Box on there is a drop-down list box at the bottom of the Navigator. With this
list box it is possible to select any of the open Writer documents so that their contents are
available for dragging and dropping. What happens when the selection is dropped is
determined by the drag mode specified by the Drag Mode button. Click the arrow next to the
Drag Mode button to see the available options (Insert as: Hyperlink, Link, or Copy).
When viewing a master document, the Navigator is quite different. For more details, see the
chapter on Master Documents in the Writer Guide.
Note

Graphics, indexes, OLE objects, and references cannot be dragged and dropped
when in the Insert as link or Insert as Copy modes.

Formatting and Styles
For a more detailed guide on using styles, see “Use templates and styles” on page 75 and the
chapter “Working with Styles” in the Getting Started guide, or the chapters “Introduction to
Styles” and “Working with Styles” in the Writer Guide.
Use Shift+F1 to check out the different buttons on the Styles and Formatting window
(Figure 18). Use the bottom list box to change the style group that is displayed. For example,
Applied Styles only shows those styles that have been used in the document.

Figure 18: Styles and Formatting
window
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When some text has a character attribute at the end of a paragraph (say bold or a hyperlink)
but the new text does not require that attribute, press the right arrow key before typing.
Deleting paragraph marks: pressing Delete at the end of a paragraph effectively moves the
text of the following paragraph into the current paragraph, and the paragraph formatting of
the top paragraph remains. Press Backspace at the start of a paragraph and the format of the
lower paragraph remains.
TIP

An aid to remember this is: the format of the paragraph that has the cursor will be
the format of the combined paragraph, unless the current paragraph is empty; in that
case, backspacing will leave the previous paragraph’s formatting.

Control+Home when in tables: In Word, Control+Home always positions the cursor to the
top of the document; in Writer Control+Home first positions the cursor at the start of the cell,
then at the start of the table and then the start of the document. Control+End has similar
behavior.

How to select multiple parts of the text
To copy, cut, format, or delete parts of the text in different areas of the document, use:
•

Control+selection with one click, double-click or sliding.

or
1) Click once on the field “STD” (STanDard) in the status bar.
The field now shows “EXT” (EXTended selection).
2) Another click and it changes to “ADD” (ADD to selection).
Note

The ADD mode is the equivalent to Control + click and EXT is equivalent to
Shift+click.

Multiple selections and tables
The following limitations apply when selections involve tables:
•

It is possible to have multiple selections within a cell, or even parts of other cells, but
only one selection is possible that involves at least one entire cell.

•

A selection that starts in a table cannot extend beyond the table.

•

A selection that starts outside a table will include the entire table (that is, a selection
cannot start outside a table and also contain a portion of a table).
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Comparison of shortcut keys
Table 6: Word vs Writer different default shortcut keys (incomplete)

Function

Word standard
shortcut

Writer standard
shortcut

Underline words not spaces

Control + Shift + W

No equivalent

Thesaurus

Shift + F7

Control + F7

Show/hide non-printing
characters

Control + Shift + *

Control + F10

Hanging indent

Control + T

No standard equivalent

“Unhang” indent

Control + Shift + T

No standard equivalent

Indent

Control + M

No standard equivalent

UnIndent

Control + Shift + M

No standard equivalent

Superscript

Control + Shift =

Control + Shift + P

Subscript

Control + =

Control + Shift + B

Remove character formatting

Control + Space bar

Right-click > Default

Remove paragraph
formatting

Control + Q

Right-click > Default

Jump to previous edit point

Shift + F5

Need to use the reminders on
the Navigator

Shift paragraph up

No equivalent

Control + Up

Shift paragraph down

No equivalent

Control + Down

Find

Control + F

Control + F

Replace

Control + H

Control + F

See AltKeyHandler.sxw (available from http://homepages.paradise.net.nz/hillview/OOo/) for
macros that extend Writer’s key shortcut ability – including the indent functionality similar to
that provided in Word.

Mouse use
Some differences are:
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•

No quick selection of paragraphs or lines by clicking to the left of the paragraph.

•

Control+click does not select a sentence, but a triple-click does (a quadruple-click
selects the paragraph).
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Selections involving tables
Tables are like one special paragraph so when selecting text using the keyboard (Shift+arrow)
from, say, above the paragraph, the whole table is selected followed by the line below it.
The location for displaying the table grid when a table has no borders is not particularly
intuitive: use Tools > Options > OpenOffice.org > Appearance and select the Table
boundaries checkbox.

Heading rows
By default new tables have a heading row. This default behavior can be changed by Tools >
Options > OpenOffice.org Writer > Table.
When creating a new table using Table > Insert Table, you can choose to turn on or off the
heading row, by checking Heading in Options > OpenOffice.org Writer > Table
Whether the top row(s) repeat at the start of each new page can be altered by selecting the
relevant top row(s) > Table > Repeat on each page. This does not change the format of the
rows, only whether they repeat at each page break.

Adjusting column widths and row heights using the
keyboard
The different methods of adjusting the column width available via Tools > Options >
OpenOffice.org Writer > Table are:
•

Fixed: Overall width of the table stays the same, but the adjoining column shrinks or
grows correspondingly.

•

Fixed Proportional: The current column and the end column change by
corresponding amounts, keeping the overall width the same.

•

Variable: Only the current column changes so the overall width of the table changes.

Use Alt and the arrow keys as follows to adjust the width of columns (or height of rows):
•

Alt and arrow keys adjusts the right side (bottom for rows).

•

Alt+Shift and arrow keys adjusts the left side (top for rows).

•

Alt+Control+left or right arrow keys adjusts the current cell only.
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Copying and pasting cells in a table
Writer never inserts new rows or columns when pasting data, it always overwrites the
contents of the cells. This makes it clear as to what will happen. To avoid overwriting cells,
first insert the required number of rows or columns.

Inserting and deleting rows or columns
If you use Table > Insert > Row or Table > Insert > Column or right-click > Insert Row or
Insert Column, you can choose whether to insert before or after the current row or column.
The icons on the Table toolbar insert below for rows and to the right for columns (opposite of
Word).
Note

This is a surprising inconsistency as Calc inserts above and to the left.

In Linux, to insert rows or columns using the keyboard: Alt+Insert > arrow key (this is hold
down Alt and Insert keys together, release the keys, then press the arrow key). To delete rows
or columns using the keyboard: Alt+Delete > arrow key. The insertion or deletion is in the
direction of the arrow key. For example, Alt+Insert > Up inserts a row above the current row.

Equal row heights and column widths
On the Table toolbar there is a long click button called Optimize. The Optimize button
becomes active when more than one cell is selected. This presents a tear-off menu for easily
adjusting row heights and column widths to being the same.

Splits and merges
Merge cells last, as you would in Word.
To merge cells: Select cells to be merged > Table > Merge cells (or use the Merge cells
button on the Table toolbar).
To split cells: Select merged cells > Table > Split cells (or use the Split cells button on the
Table toolbar).
To split a table (horizontally): Table > Split Table.
To join two tables, they need to be one below the other, then Table > Merge Table. If there is
a table above and below the current table you will be prompted for which one you wish to
join.
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Sorting
To sort a table:
1) Select the cells to be sorted; do not include the headings. The option to sort only
becomes available when something is selected.
2) Tools > Sort.
Unlike Word, the sort dialog uses column number rather than the names of the column.

Entering numbers and formulas
Unlike Word, tables in Writer can work much more like spreadsheets. For example,
calculated values change as the data is input (no more selecting and pressing F9 to update
calculated results).
With number recognition turned on, when entering a number Writer will automatically format
the number according to a specified number format. To change this behavior, right-click
when the cursor is in a table and click on Number Recognition to deselect it.
To change the number format, select the cells, Table > Number Format.
To enter a formula like SUM():
1) Select the cell where the result is to go.
2) Press F2 to display the Formula bar.
3) Click and hold the Formula button to display the formula menu.
4) Select the desired function (list separator is for separating constants, for example
=mean 5 | 12 | 20).
5) Click and drag on cells to input ranges.
6) Press Enter to finish.
To enter a formula like “this cell plus that cell minus that cell”:
1) Select the cell where the result is to go.
2) Press F2 to display the Formula bar.
3) Click on a cell.
4) Type or select the desired operator.
5) Click on the next cell.
6) Repeat steps 4 and 5 until done.
7) Press Enter to finish.
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Creating a table from a data source
To create a table from a data source:
1) Display the Data source viewer (F4).
2) In the Data explorer window, navigate to the desired table or query.
3) Drag the name of the table or query into the document.
4) Select the desired fields and set other properties as required in the dialog.

Charts in Writer
Charts copied from a Calc spreadsheet and pasted into a Writer document are, by default,
embedded objects. Unlike doing this in Microsoft Office, only the relevant data for the chart
is embedded. In Microsoft Office copying and pasting a chart also embeds it, but if the Excel
workbook was 8 MB in size (not unrealistic for a spreadsheet) then each chart pasted into a
Word document would increase the Word document by 8 MB.
Linking of charts does not exist.

Customizing the user interface
Most functions are found in similar places in both programs, but a few are slightly different,
and the degree of control varies. Table 6 summarizes where to find the setup choices.
Table 7: Customizing the user interface
To do this

In Word

In Writer

Change measurement system

Tools > Options >
General

Tools > Options > OpenOffice.org
Writer > General

Turn off Auto completion

Not applicable

Tools > AutoCorrect. In the Word
completion tab, deselect Enable
word completion.

Turn on/off Help Agent

Help > Microsoft
Word Help > Options

Tools > Options > OpenOffice.org
> General

Set up document window
(rulers, status bar, default
toolbars, etc)

View > select required
items

View > select required items

Customize toolbars

Tools > Customize

Tools > Customize

Customize menus

Tools > Customize

Tools > Customize

Display font names in their font
(in toolbar drop-down font list)

Tools > Customize >
Options

Tools > Options > OpenOffice.org
> View, select Show preview of
fonts
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To do this

In Word

In Writer

Always show full menus
(include unavailable and littleused items)

Tools > Customize >
Options

Tools > Options > OpenOffice.org
> View, select Show inactive menu
items

Show/hide ScreenTips
(ToolTips) on toolbars

Tools > Customize >
Options

Tools > Options > OpenOffice.org
> General

Always create backup copy

Tools > Options >
Save

Tools > Options > Load/Save >
General, select Always create
backup copy

Autosave every x minutes

Tools > Options >
Save

Tools > Options > Load/Save >
General, select Save AutoRecovery
information every , and choose a
time in the Minutes list

Show paragraph marks, tabs,
etc.

Tools > Options >
View

Tools > Options > OpenOffice.org
Writer > Formatting Aids, select
required items

Change file locations

Tools > Options > File
Locations

Tools > Options > OpenOffice.org
> Paths

Change user information

Tools > Options >
User Information

Tools > Options > OpenOffice.org
> User Data

Set up AutoCorrect and
AutoFormat options

Tools > AutoCorrect
Options

Tools > AutoCorrect > Options,
select required items

Write, edit, and review documents
Most writing, editing, and reviewing techniques in OOoWriter are similar to those in
Microsoft Word, but the details often vary.
Table 8: Write, edit and review documents
To do this

In Word

In Writer

Jump quickly to other parts of
a document

Edit > Go to

Edit > Navigator (or F5),
double-click on required heading,
figure, table, etc.

Choose language for spelling
checker

Tools > Language > Set
Language

Tools > Options > Language
Settings > Language. (Note:
OpenOffice.org has no grammar
checker.)

Ignore some text when
checking spelling

Select text; Tools >
Language > Set Language
> Do not check (or)
Format > Style > Modify>
Format > Language

Select text; right-click,
Character > Font > Language =
[None] or the real language of the
selected text, if that is foreign.
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Write, edit, and review documents

To do this

In Word

In Writer

Recheck spelling

Tools > Spelling &
Grammar > Recheck
Document

Always rechecks

Find and replace text,
formatting, and styles

Edit > Replace > More;
choices as needed

Edit > Find & Replace; details
are a bit different

Use wildcards in find and
replace

Edit > Replace > More >
select Use Wildcards
checkbox

Edit > Find & Replace, click on
the More Options and select
Regular expressions; wildcards
themselves are different. See the
section on Regular expressions in
the chapter “General Differences
in use between Microsoft Office
and OpenOffice.org”.

Choose, create, or edit a
custom dictionary

Tools > Options >
Spelling & Grammar >
Custom Dictionaries

Tools > Options > Language
Settings > Writing Aids

Create exception (exclude)
dictionary

File > New, type words,
Save As > text only, file
extension .EXC

As for custom dictionary, but
after clicking on the New button,
select Exception (-) in the New
Dictionary dialog

Track changes (choose
options)

Tools > Options > Track
Changes

Tools > Options >
OpenOffice.org Writer >
Changes

Protect document for editing

Tools > Protect Document

Edit > Changes > Protect
Records
(Password needs to be at least 5
characters)

Mark and track changes

(Word 2000) Tools >
Track Changes >
Highlight Changes

Edit > Changes > Record

Insert comments associated
with a change

Highlight text; Insert >
Comment

Edit > Changes > Comment

Insert notes (comments not
associated with a change)

Highlight text; Insert >
Comment

Insert > Note

Show changes as pop-up text

Options > View >
Screentips

Tools > Options >
OpenOffice.org > General

Merge documents

Tools > Merge Documents

Edit > Changes > Merge
Document

Accept or reject changes

View > Toolbars >
Reviewing

Edit > Changes > Accept or
Reject

Change document properties

File > Properties

File > Properties

Get a word count

Tools > Word Count

Tools > Word Count
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To do this

In Word

In Writer

Create AutoText entry

Select text; Insert >
AutoText > New

Edit > AutoText (or) Control+F3

Insert AutoText

Type shortcut and press
F3

Type shortcut and press F3; or
type Name and press Enter.
Writer distinguishes between the
“name” and the “shortcut” of an
autotext. Word does not.

AutoText in Writer always ends with a paragraph mark. So for a short in-line shortcut, it is
better to use AutoCorrect.

Control page layout
This section covers such things as margins, headers, and footers.
Writer and Word have somewhat different notions of page layout.

Word’s notion of page layout
Page layout is a property of the document as a whole. If you change the page layout (for
instance, set the document to landscape), it changes for the entire document. You can then
arrange for specific sections to have a different layout.

Writer’s notion of page layout
Page layout is a property of the page style (for example, First Page, Index and Default). If you
change the page layout for one page style (for instance, set Default to have a header with page
numbers), only that style will be affected.
Using page styles gives Writer some very useful features. For instance, you can define the
First Page page style so that, after you have typed the first page, the style switches to Index
(or any other style you choose). You can then set Index so that it is followed by Default.

Comparison for page layout
Table 9: Control page layout
To do this

In Word

In Writer

Define margins

File > Page Setup > Margins

Format > Page > Page

Specify different headers
and footers on first, odd,
and even pages

File > Page Setup > Layout >
Headers and Footers section

Format > Page, select
required items
Define different page styles for
First, Left (even), and Right
(odd) pages, using Header and
Footer tabs
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Control page layout

To do this

In Word

In Writer

Edit headers and footers

View > Headers and Footers,
then you can type or insert fields;
you can also double-click in
existing header or footer regions

After you have specified
Header and Footer areas for a
page, they are always active.
Single-click to type or insert
fields

Change from roman to
arabic page numbers in
the footer of a page

Insert a section break, deselect
“Same as Previous” in the second
section, define a new footer with
page numbers restarting at 1 in
Arabic numerals

Insert a manual page break and
apply a different page style

Use paragraph styles for
page layout

Can define paragraph styles with
offset from left margin, with
heading styles aligned left or
right

Can define paragraph styles
with offset from left margin,
with heading styles aligned
left or right

Use columns for page
layout

Insert continuous sections to
switch from single to multiple
columns on one page

Format > Page > Columns
(or)
Insert > Section > Columns
(or) Format > Columns

Use frames or text boxes
for page layout

Frames are used in Word 97 but
mostly replaced by text boxes in
Word2000 and 2002; can be
linked to flow text from one to
next, as in a newsletter

Insert > Frame (can link
frames to flow text from one
to next, as in a newsletter);
“text boxes” are fields, not
positioning devices

Use tables for page layout

Table > Insert > Table (use dialog
to format)

Insert > Table (use dialog to
format)

Put portrait headers on
landscape pages

Use rotated text box linked to
header

Use rotated text in a frame

Set first page number to
greater than 1

Insert > Page Numbers > Format

In first paragraph on first
page, Format > Paragraph >
Text Flow > Breaks, select
Insert and With Page Style,
choose the page style, specify
the page number

View and edit facing
pages

File > Print Preview; click Zoom
button to enable editing

File > Page Preview; cannot
edit when previewing,

Reduce page count by 1

File > PagePreview, click
ShrinkToFit button.

See
http://homepages.paradise.net.
nz/hillview/OOo/ShrinkToFit.
sxw.
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Use templates and styles
Table 10: Use templates and styles
To do this

In Word

In Writer

Find which template is
associated with a document

Tools > Templates and Addins

File > Properties > General
tab.

Specify default template

"Normal" template is default

File > Templates > Organize
lets you set any template as
default

Create a new template

File > Save As, set type to
Document Template (.DOT)

File > Templates > Save

Edit a template

File > Open, choose template

File > Templates > Edit

Copy styles between
templates

Tools > Templates and Addins > Organizer

File > Templates > Organize.
There, you can copy styles with
drag and drop between templates.

Create a new document
from a template

File > New (opens a list of
templates)

File > New > Templates and
Documents

Apply a different template
to a document

Tools > Templates and Addins > Attach, select template,
Open

Start a new document based on
the different template; copy
contents of old document into
new document.

Apply a style to text

(Word 2000) Select from
Style List or Style dialog
(XP) Can also use task pane.

Format > Styles and
Formatting (or press F11),
double-click the style in list;
after the second use, paragraph
styles appear in Apply Style list
on the Formatting toolbar.

Change a style definition

(Word 2000) Format > Style
> Modify; (XP) can also
select in task pane and click
Modify

Select a style in the Styles and
Formatting window, right-click,
and choose Modify.

Create a new style

Format > Style > New

Right-click in Styles and
Formatting window, then click
New.

Use outline numbering

Format > Style, select style >
Format > Numbering

Tools > Outline Numbering

Drop caps

Format >Drop Cap
One character only, can not
be part of a style.

Format > Paragraph > Drop
Caps tab
Drop caps can be part of a style.
Can be >= 1 char or word.
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Use templates and styles

Font size
When a style is based on another style, it is possible to set the font to being a percentage of
the font size of the original style. In the font size field simply type the number followed by a
percentage sign, for example 120%. This way, changes to the underlying style will be better
reflected in this style. To change it back to being an absolute font size type the number
followed by the characters “pt”, such as 12pt. It is also possible to specify how many points
larger or smaller, for example +2pt for 2 points larger, or -2pt for two points smaller.

Space between paragraphs and page breaks before
In Writer, some paragraph properties behave differently to the way they behave in Word.
Specifically:
•

Space before if at the top of a page is ignored.

•

Space between paragraphs: the greatest of space above and space below for the two
paragraphs is applied.

•

Page break before: if at the top of a page, does not create a blank page.

This makes using styles possible without having to apply direct paragraph formating to fix
issues afterwards.

Fields
For a comparison of fields between Writer and Word, see Chapter 2, “Sharing Files with
Microsoft Office Users”.
Table 11: Use of fields
To do this

In Word

In Writer

Insert a field

Insert > Field
(or) CTRL + F9 for blank
field

Insert > Fields and choose the
requested field.

Define a number range field

Insert > Field, use SEQ
(sequence)

Insert > Fields > Other >
Variables tab, then Number
range in the Type area

Insert a bookmark

Select text; Insert >
Bookmark

Select text; Insert > Bookmark

Insert a cross-reference to a
bookmark

Insert > Cross Reference,
choose Bookmark as type

Insert > Cross Reference >
Bookmark1

1 For macros that aid in working with references see http://homepages.paradise.net.nz/hillview/OOo/. For a more
detailed discussion on references, see the latest document available from
http://www.openoffice.org/issues/show_bug.cgi?id=28058.
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To do this

In Word

In Writer

Insert a cross-reference to a
heading

Insert > Cross Reference,
choose Heading as type

Either bookmark the heading or
use Insert > Cross Reference >
References tab > Set Reference
to mark the heading, then Insert
> Cross Reference > References
tab > Insert Reference.

Insert a cross-reference to a
figure or table

Insert > Cross Reference,
choose type

Insert > Cross Reference >
References tab > Insert
Reference > Figure (or Table)

Use conditional content

Use IF or other fields, or
styles (all workarounds)

Insert > Fields > Other >
Variables (among other ways)

Work with large or complex documents
Major differences exist in the use of master documents. The table does not attempt to
summarize all these differences.
Table 12: Work with large or complex documents
To do this

In Word

In Writer

Create a table of contents, list
of figures, or an alphabetic
index

Insert > Index and
Tables

Insert > Indexes and Tables >
Indexes and Tables

Insert index entries

ALT + SHIFT + X

Insert > Indexes and Tables >
Entry

Create a bibliographic
database

Need to use other
package

Tools > Bibliography Database

Insert bibliographic references
into text

Link to field in database

Insert > Indexes and Tables >
Bibliography Entry

Insert footnotes and endnotes

Insert > Footnote

Insert > Footnote

Insert other files

Insert > File, choose
Insert or As Link

Insert > File

Cross-reference between
documents

Use Includetext fields

Currently have to remember the
name of the set reference. Reference
will show correctly when in master
document. (Or use the
OutlineCrossRef3-fr-3 macro
available from http://ooomacros.org/
user.php#113812.

Use master documents

Some experts do not
recommend using Master
Documents in Word.

File > Send > Create Master
Document; use the Navigator (F5)
to insert subdocuments.
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Work with graphics

Work with graphics
Most graphics work should be done outside Word or Writer, with the graphic files embedded
or linked to the Word or Writer file. However, you can do some simple graphics using the
drawing tools in Word or Writer. This table covers the basics.
Table 13: Work with graphics
To do this

In Word

In Writer

Create Drawing objects

(Word 2000) View > Toolbars >
Drawing; (XP) Insert > Picture
> New Drawing

Click Show Draw Functions
icon in the Standard toolbar.

Combine graphics objects
and drawing objects

(Word 2000) Edit > Picture >
Reset Picture Boundary; (XP)
Use drawing canvas

Place all objects in a frame

Insert graphics files into a
text document (embed or
link)

Insert > Picture > From File,
choose Insert or As Link

Insert > Picture > From File

Anchor graphics

Format > Picture > Layout >
Advanced > Picture Position

Use icons on the Drawing
Object Properties or Frame
toolbar (these toolbars replace
the Formatting toolbar when a
drawing object or frame is
selected) or right-click and
choose from pop-up menu, or
click Format > Picture

Wrap text around graphics

Format > Picture (or Object) >
Layout

Use icons on the Frame
toolbar, or right-click and
choose from pop-up menu, or
click Format > Picture >
Wrap

Crop graphics

Format > Picture > Crop, (or)
click Crop tool on Picture
toolbar

Format > Picture > Crop
(No tool for dragging crop
area)

Create captions for
graphics

Select graphic; Insert >
Reference > Caption

Select graphic; Insert >
Caption

Annotate graphics

Use drawing objects; group, or
place in frame or on drawing
canvas (XP)

Place all objects in a frame

Insert watermark

Format > Background > Printed
Watermark > Picture (or Text)
Watermark

Format > Page >
Background tab
or create drawing object,
Wrap > In Background,
Anchor > To Page
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Mail Merge
Mail merging is significantly different in Writer and Word. See Chapter 11, “Using Mail
Merge” in the Writer Guide.

Envelopes
Adding an envelope
Insert > Envelope

Removing an envelope
1) Place the cursor at the beginning of the envelope page.
2) If the Styles and Formatting window is not open, press F11 or use Format > Styles
and Formatting to display it.
3) Change to the Page Styles option. It is the fourth icon from the left.
4) Double-click on Default.
5) Remove the remaining elements that make up the envelope.

Page styles
Modify a page style
In Writer all pages have a page style. To modify the page style of the page where the cursor is
positioned, use Format > Page.
Caution

As the page style is being changed, all pages with this style will be changed as well.

Create a style
To create a new page style:
1) If the Styles and Formatting window is not currently displayed, press F11 to display it.
2) Click Page Styles in the Styles and Formatting window (fourth icon from left).
3) Right-click in a free area of the Styles and Formatting window > New.
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Page styles

The Page Style dialog
Click Format > Page. The Page Style window opens.
Organizer tab

Name: Nothing tricky here, simply a name to help the user remember what the settings are
for.
Next style: This setting specifies what page style to use at the next page break (manual or
automatic) for any page that has this page style. Set it to a different page style when the page
style is only for one page (such as the first page of each chapter), otherwise this should be the
same as Name to keep the same page style for the following pages.
Page tab

Paper format : Format is the paper size, the other settings have the same names in Word (on
the paper size tab of page setup).
Margin : Same as for Word. Each setting represents the distance from the edge of the page,
but see “Header and footer tabs” as the location of headers and footers relative to the
margins is different.
Layout settings: Page layout is for specifying whether the page style is mirrored (used for
left and right pages). There are more options here than in Word, but there is not a different
first page option, that is because it is handled by the Next style setting as mentioned above in
Organizer tab. Format refers to the format of page numbers. Register true is to make the text
line up better at the top of the page (see help for more details).
Background tab

For specifying a background color or graphic (watermark). (An alternative to this with more
flexibility is to create a drawing object, then use Arrange > To Background, Anchor > To
Page.)
Header and footer tabs

Headers and footers are printed between the margins of the page rather than in the top or
bottom margins as they are in Word. Another way of saying this is that for the top of a page
the area between the edge of the page and the top margin is always blank, next is the header,
and after the header, the main text area for the page.
Height: AutoFit height allows the header or footer to grow and shrink depending on their
contents.
Spacing specifies the distance between the header/footer and the main text area on the page.
Dynamic spacing allows the header/footer to expand into the area between the header/footer
and the main text area.
The left and right margins are indenting from the margins of the page and cannot have
negative values.
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The More button is for specifying borders and backgrounds for the header/footer area. In
some versions of Word this approach was used to create a watermark. Since it is possible to
have graphics in the background of the main document, this is not the required way of having
a watermark in Writer.
Borders, columns and footnote tabs

These tabs are for specifying the borders (lines around the outside), number and widths of
newspaper style columns and defining the area for footnotes (if any) for the page style.

Page breaks and page numbering
Changing the style used for a page and changing
the numbering sequence
To insert a page break and change page style or page numbering, method 1:
1) Press Control+Enter.
2) Cursor will be in the first paragraph of the new page.
3) Format > Paragraph > Text Flow tab.
4) Breaks will be enabled.
5) Select With Page style, specify the page style to use and specify the page number to
start from.
To insert a page break and change page style or page numbering, method 2:
1) Insert > Manual Break
2) By default it will specify Page breaks.
3) Choose the page style in the Page style list.
4) Select Change page number.
5) Enter the new starting page number.

To insert page numbering
1) Define a page style with header or footer turned on.
2) Position the cursor in the header or footer (use the mouse or the shortcut keys
Control+PageUp for Header or Control+PageDown for footer).
3) Optionally type: Page <space>.
4) Insert > Fields > Page Number.
5) Optionally type <space> of <space>, then click Insert > Fields > Page Count.
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Page breaks and page numbering

To insert a field that calculates a different page count (for example, when you have a title
page but want to have the remaining pages say page 1 of 2 (instead of page 1 of 3 ):
1) Press F2 to display the text formula bar.
2) Type =page – 1.
3) Press Enter.
Note

Unfortunately this field does not automatically update, so press F9 to update it
before printing.

Page numbers on portrait and landscape pages in
the same place and orientation
1) Create a style for landscape pages. Set the margins for the landscape style such that
they correspond with the portrait style when rotated (top = left, bottom = right, left =
bottom and right = top). For page numbering on left, turn on headers; on right –
footers. Select Use dynamic spacing.
2) Create a style for the landscape header or footer based on the style for the portrait
header or footer. (In the Styles and Formatting window, select the style that is used
for the portrait header or footer > right-click > New.) Change the font position to 270°.
If the page numbering is on the bottom choose left alignment, for the top choose right.
3) Insert the page break and choose the page style just created (see above); do not change
the numbering.
4) In the relevant header/footer (as per step 1) insert the page number field.

Conditional text
In Word the only way to have conditional text is with the “if” field2. The equivalent in Writer
is the field “Conditional text”.
To insert a conditional field in Writer: Insert > Fields > Other > Functions > Conditional
text or Control+F2 > Functions > Conditional text.
There is also a field “Hidden text” that hides the text when the condition is true.
Working with the relevant fields for conditional text, both in Word and in Writer, means that
only small amounts of text can be conditional. However, there are times when having whole
paragraphs or sections of text be conditionally hidden is very convenient. Some examples:
A test so that the same document can be used for the test itself and for the model answers.
Technical documents where the same document with variations can be used for similar
models of equipment.
2 To the best of the Author’s knowledge.
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Writer provides a field for conditionally hiding paragraphs and the ability to conditionally
hide sections. Here is an example to show how this could be done:
1) Ensure that hidden text is viewable: Tools > Options > OpenOffice.org Writer >
Formatting Aids, select both “Fields: Hidden text” and “Fields: Hidden paragraphs”.
Note

Conditionally hidden sections are not visible regardless of these settings if the
condition for hiding them is true.

2) At the top of the document: Insert > Fields > Other > Variables.
3) Name: DocType. Value: Model Answers.
4) At the start of a one paragraph answer: Insert > Fields > Other > Functions >
Hidden Paragraph. For the condition type DocType == “Test” (To make this easier to
insert repeatedly, create an autocorrect entry).
5) For longer answers: Enter the model answer, select it, Insert > Section, select Hide,
and enter DocType == “Test” for the condition.
6) To print the document for a test, double-click the field at the top of the document
created in steps 2 and 3, and change the value to Test. Print as usual.
Note 1

The field “Input list” has a name but this is not a variable so its value cannot be
used in the condition.

Note 2

To keep adding sections, it is easier if the selection does not include the last
paragraph. But if the last paragraph is selected, simply move to the end of the
document (Control+End ) and then press Alt+Enter.

Master documents
OOo Help covers the basics of using master documents, or see “Work with large or complex
documents” on page 77, or for even more information see chapter 13 “Working with Master
Documents” in the Writer Guide.
It is possible to insert cross-references across subdocuments but the names of the references
must be typed in rather than selected from a list.
Use Insert > Fields > Other > References.
A macro to help insert references to headings, including references across documents that
will be subdocuments in a master document, is available in a document called
OutlineCrossRef3-fr-3.zip available from http://ooomacros.org/user.php#113812.
Note

There is no way to have a landscape page in a subdocument remain as a landscape
page when included in the master document. The workarounds are to have the
landscape page be part of the master document rather than a subdocument or to have
the entire subdocument as landscape.
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Migration Guide

Chapter 6
Differences in Use between
Calc and Excel

Overview

Overview
This chapter summarizes the differences in use between OpenOffice.org Calc 2.0 and
Microsoft Excel (various versions). The information in this chapter builds upon the
information given in Chapter 4, “General Differences in Use between OpenOffice.org and
Microsoft Office”.

The Calc interface
The main Calc workspace is shown in Figure 19.
Title Bar

Formatting
Tool Bar

Active Cell
Indicator

Menu Bar

Standard
Tool Bar

Formula Bar
Column Headers

Active Cell

Row
Headers
Figure 19. Parts of the Calc window

Terminology
Table 14 summarizes some terminology differences between Calc and Excel.
All of the chapters in this guide and in the Calc Guide use the OOo Calc terminology.
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Table 14: Excel vs. Calc terms
Object

Excel

Calc

Individual cell (A1)

Cell

Cell

Entire file

Workbook

Spreadsheet

One tabbed sheet in a workbook (Sheet 1)

Worksheet

Sheet

Callouts in cells which appear when the mouse
pointer is positioned over the cell

Comments

Notes

User interface
Calc uses a Single Document Interface (SDI). This means that each document has its own
window in which only one document is displayed at a time. Excel uses a Multiple Document
Interface (MDI) where all open documents are displayed within one parent window. When
you close the parent window, all files are also closed.
Two of Calc’s strong points are the accessibility of information about the active document
and the ease of navigation of an SDI. Each Calc window provides menus, toolbars and other
features that directly relate to the document open in that window.
When more than one OpenOffice.org document is open, you can switch between the active
document and other open documents in several ways:
•

From the Window menu, select the document you want to become active.

•

Use the Restore Down button on the Title Bar to minimize the active document and
reveal other open documents.

•

Select a document from your desktop’s Panel or Taskbar to activate it.

•

Close the current document to access other open documents.

•

Use the Alt+Tab shortcut keys to cycle through the open documents.

Drag and drop
Drag and drop works slightly differently in Calc than it does in Excel:
•

In Excel, after you select the cell or range to be moved, you need to position the
pointer fairly precisely on the border of the cell or range for drag and drop to be
available. In Calc, after selecting the cell or range, you can position the pointer
anywhere within the range.

•

In Calc, to drag and drop a single cell, do this:
1) Select the cell.
2) Drag to select at least one additional cell.
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Drag and drop

3) Drag back so that only the desired cell is selected. Then the cell can be dragged
and dropped.
•

In Calc, to leave the source cell or range intact while dragging and dropping (in other
words, to create a copy of the source cell or range), first drag in the normal way, then
just before dropping, press and hold the Ctrl key, then release the mouse button.

Keyboard shortcuts
Table 15: Selected Excel and Calc default keyboard shortcuts
Function

Excel Shortcut

Calc Shortcut

Rearranges the relative or absolute
references (for example, A1, $A$1,
$A1, A$1) in the input field

F4

Shift+F4

Edit cell comment (known as
“notes” in Calc)

Shift+F2

Control+F1

Fill right or Fill down

Control+R or Control+D

No equivalent

Go to specific cell

F5

F5 (shows Navigator)

Insert Function

No standard equivalent

Control+F2

Enter into all currently selected
cells

Control+Enter

Alt+Enter
Alt+Shift+Enter (also
applies the cell format).
In both cases cells must
be contiguous.

Range lists
Excel allows all parameters to be range lists. Some examples are:
=SUM(A1,A3) is the sum of two cells (function has 2 parameters).
=SUM((A1,A3)) is the same, but with one parameter being a range list.
=INDEX((A2:A3,C2:C3),1,1,2)
Calc only allows range lists in the INDEX function. For example:
=INDEX((A2:A3;C2:C3);1;1;2) returns the first cell of the second range in the range
list.
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Deleting cell contents
In Excel, pressing the Delete key instantly deletes the contents of the cell. In Calc, pressing
Delete calls up a dialog box where you can specify what to delete:
•

Strings

•

Numbers

•

Date & Time

•

Formulas

•

Notes

•

Formats

•

Objects

The items checked by default are: Strings; Numbers; Date & Time; Formulas; and Notes.
Thus, pressing Delete and then Enter will delete the items checked by default.
You can bypass the dialog and instantly delete the items checked by default by pressing the
Backspace key rather than the Delete key.

Filling down or to the right
Using the Fill Down (or Fill Right) feature
In Excel, it is possible to copy and paste a cell to a range of cells below or to the right of the
target cell by selecting a range, with the source cell at the top (when filling down) or at the
left (when filling to the right); then use the keyboard shortcut Ctrl+D (to fill down) or
Ctrl+R (to fill to the right). There is also a menu path that accomplishes the same task as the
keyboard shortcuts.
In Calc, the same features are available, but only through a menu path, not through keyboard
shortcuts. Also, in Calc, it is possible to fill up and to the left. The menu path is: Edit > Fill >
Down (or Up, Right, or Left).

Using the fill handle
In both Calc and Excel, the fill handle can be used to copy contents of a cell down or to the
right. This feature works somewhat differently between Calc and Excel.
Fill Handle

To use the fill handle, select the source cell, position the pointer over the fill handle so it
becomes a small plus sign, and then drag either down or to the right.
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•

In Excel, the above action will copy the contents of the cell.

•

In Calc, if the source cell contains only letters, or a string of letters and numbers but
not ending in a number (example: A4B), then the source cell will be copied exactly.

•

If the cell is numeric, the number will increment by 1 with each additional cell
(example: 5, 6, 7, ...; or 1.5, 2.5, 3.5, ...). If the source entry is a string which begins
with or ends with a number, the number component of the string will increment by 1
(example: A1, A2, A3, ...).

•

In Calc, it is possible to copy the source cell exactly, without incrementing, by holding
the Ctrl key while clicking the fill handle and dragging.

In either Excel or Calc, if there are two adjacent cells which contain numerical entries,
selecting both cells and then using the fill handle to extend the series will result in the same
increment between the “filled” cells as was present between the two source cells. For
example, if cell A1=1.0 and cell A2=1.1, selecting these cells and using the fill handle will
yield: A3=1.2; A4=1.3; etc.

Default number format
Calc and Excel use different default number formats.
•

With Excel, the cells are set to the “General” category number format., so if you
entered 25.12345 in a cell it would display “25.12345”.

•

In Calc a default formatted cell is set to the “Number” category in the “General”
format. Thus, if 25.12345 is entered, 25.12 will be displayed.

Interpreting cell contents
In Calc if a cell is defined as text, even if the cell contains a number, then that cell is treated
as text, which means it has the numeric value zero for formulas.
For example, if cell A1 is formatted as text and contains the character “1”, in Excel a formula
=A1+1 would return the value 2, but in Calc it would return the value 1.
In functions, such an entry will be ignored rather than treated as zero. For example, the
function AVERAGE will not treat a text entry as zero, but will ignore it. If cell A1 is a text
entry of “1”, and cell A2 is a numerical entry of “10”, =AVERAGE(A1:A2) would be 10, not
5.

Limitations
The maximum number of sheets in Calc is 256. In Excel, the number of sheets according to
the Microsoft web site is “Limited by available memory (default is 3 sheets)”.
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Form fields
List boxes in Calc can either have multi-selection or not, whereas Excel has two multiselection modes: multi and extend. In Excel a multi-selection listbox’s link to a cell is
ignored. In Calc the link works, but if more than one item is selected the cell’s value is set to
#N/A.
In Calc each option button has its own link to a cell, setting its value to true or false
depending on whether the option is selected. In Excel the cell link returns the number of the
selected option button.

Relative addressing of sheets
In Calc it is possible to have relative addressing of sheets. As with column and cell
references, the dollar sign is used to signify that the sheet name is absolute.
=$Sheet2!$A$1 always refers to the first cell on sheet 2.
=Sheet2!$A$1 when on sheet one and copied to another sheet will refer to the first cell of
the next sheet.
This is not possible in Excel.

Named ranges and “Natural Language”
formulas
It is possible, in some versions of Excel, to have the same range name on different sheets.
This is not possible in Calc. However, if the duplicated range name in Excel refers to the
same cell in each case, then it can be simulated in Calc with a range name without the sheet
being specified and thus the range name refers to the specified cell on the current sheet.
Calc does have Natural Language. This is where column or row labels are used (without
defining them as range names) in a formula. In Excel, to refer to a cell, a space is used
between the label names. In Calc an exclamation mark “!” (sometimes called pling) is used.
In Calc the names are enclosed in single quotes (done automatically by Calc if the label starts
with a letter and only has alphanumeric characters). To turn this feature on or off use: Tools >
Options > Spreadsheet > Calculate > Automatically find column and row labels.

Array formulas
Calc supports array formulas (formulas entered using Control+Shift+Enter), but Calc can not
have array constants in a formula. The work-around is to have the constant values in cells on
a sheet and refer to them.
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Array formulas

Some Excel array formulas seem to rely on the way that Excel is calculating a result in a nondocumented way–such a practice is not a good idea even within Excel only, and certainly not
a good idea when importing a file containing such a formula into Calc.
Note

OpenOffice.org help refers to array functions as matrix functions.

Functions
Caution

An important difference between Excel and Calc regarding functions is that the
values supplied to a function (which are called arguments in Excel and parameters
in Calc) have different separators. Calc always uses semicolons to separate
parameters in a function. Excel uses either commas or semicolons, depending on
the system (for example commas on English systems, semicolons on German
systems). Calc will generate a “#NAME?” error if you use a comma in place of a
semi-colon.

Optional parameters in functions
Some formulas have more than one optional parameter at the end of the parameter list. In
Excel it is possible to leave an optional parameter blank and specify a later parameter, but
this is not possible in Calc. When using Calc functions, parameters marked as "optional" can
be left out (or left empty) only when no parameter follows.
For example, to calculate an annuity by using the Present value function, PV(Rate; NPER;
PMT; FV; Type), without the Future Value variable (FV):
•

In Excel the formula =PV(0.05,10,100,,1) returns -$810.78

•

in Calc =PV(0.05;10;100;;1) returns Err:511 (Variable missing).

When you enter the PV function in Calc with the FV variable empty, a message box is
displayed offering to change the incorrect input to “=PV(0.05;10;100;1)”:

Figure 20: Function error message
This, too, is incorrect as it will produce a value of -772.79.
The work-around is to put values in for the missing parameters. For the above example,
putting a zero in for the blank parameter returns the correct result for the annuity, -$810.78.
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Date values in financial functions
In Excel some of the financial functions accept string parameters for dates; in Calc financial
functions require a serial number, although you can simply type in the dates in date format
without quotes.

Analysis Addin functions
Whenever an Excel Analysis ToolPak function has the same name as a Calc function, there is
an equivalent in the Calc Analysis AddIn function but with a trailing _ADD. This ensures
compatibility with Excel but without changing the behavior of Calcs built-in functions.
For example, the functions EFFECT and CONVERT provided by the Excel Analysis ToolPak
are named EFFECT_ADD and CONVERT_ADD in Calc and return the same results.
The functions whose names end with _ADD return the same results as the corresponding
Microsoft Excel functions. Use the functions without _ADD to get results based on
international standards. For example, the WEEKNUM function calculates the week number
of a given date based on international standard ISO 6801, while WEEKNUM_ADD returns
the same week number as Microsoft Excel.

Differences in function results
Calc and Excel handle the missing Reference parameter with the Cell function,
CELL(Info_type; Reference), differently. If Reference is missing, Calc uses the position of the
cell in which this formula is located. Excel uses the reference of the cell in which the cursor
is positioned.

Functions not implemented or imported
Excel functions which are not imported or implemented in Calc include INFO and
GETPIVOTDATA. Excel has no equivalent for Calc’s ARABIC function which calculates the
value of a Roman number.
There are issues when importing both the Ceiling function, CEILING (Number; Significance;
Mode), and the Floor function, FLOOR(Number; Significance; Mode). If both parameters
Number and Significance are negative and the Mode value is equal to zero or is not given, the
results in OpenOffice.org and Excel will differ after the import has been completed. If you
are exporting a Calc spreadsheet to Excel, use Mode=1 to see the same results in Excel as in
Calc.
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DataPilot or Pivot Table
DataPilots are Calc’s equivalent to Excel’s Pivot Tables. However there are a number of
limitations. Pivot tables import from Excel into Calc (although the cells do not have the
PivotTable shading), but as soon as they are worked on these limitations become apparent.
The limitations are:
•

There is no PivotChart facility, but a DataPilot can be used as the data source for a
chart.

•

The user interface allows a maximum of 8 fields in the data, row or column areas. (An
alternative interface which allows more is available from
http://homepages.paradise.net.nz/hillview/OOo/ in a document called
MyDataPilot.sxc).

•

There is some ability to group data (for example, a date field grouping by week or
quarter but not by month). The work-around is to create a new column with a formula
for calculating the grouping, for example =Month().

•

You can not define different formats for different fields.

•

Calc can have formulas based on things like “Difference From” or “% of”, but can not
have its own custom fields (work-around, create new columns to calculate the desired
values).

•

The Application Program Interface specification is incomplete for writing macros that
work with DataPilots—for example; the ability to control, through another program
such as OpenOffice.org’s own macro language BASIC, whether the tables have grand
totals or have access to DataPilot’s created from external data.

AutoFilter
There are a number of AutoFilter differences between Excel and Calc:
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•

There is only one AutoFilter active at a time, for a spreadsheet document, unless using
database range names. The rows remain hidden but the drop-downs in the first row
disappear on applying AutoFilter elsewhere. To have more than one AutoFilter active
at the same time, define a database range name (Data > Define Range) for the data,
then it is possible to have more than one AutoFilter active on the one sheet (which
Excel can not do.)

•

The remaining visible row numbers do not change color to warn you that there is a
filter in place.

•

Error values do not show as an option in the drop-down lists when cells in the column
have errors.

•

In the drop-down lists, the equivalent to Excel’s “Custom” is called “Standard.”
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•

The top 10 in the drop-down list is literal, but to get the same degree of control you
can use Standard and specify “largest”, “largest%”, “smallest” or “smallest%” in the
condition field.

•

Use regular expressions to specify criteria to select rows based upon the text in the
cells. To do this:
1) Choose “Standard” from the drop-down list.
2) Click More so that the rest of the dialog is displayed.
3) Check Regular expressions.

Table 16 has some examples to help an Excel user use regular expressions.
Table 16: Example regular expressions for AutoFilter
Excel custom command

Comparison Field

Equivalent Regular
Expression

Begins with x

=

^x.*

Does not begin with x

<>

^x.*

Ends with x

=

.*x$

Does not end with x

<>

.*x$

Contains x

=

.*x.*

Does not contain x

<>

.*x.*

You are not limited to these regular expressions. They are included here to show how to
achieve the same result for AutoFilter in Calc as can be achieved in Excel.

Inserting notes (“comments” in Excel)
In Excel, a comment could be added by right-clicking on a cell and selecting Insert
Comment from the context menu. Also, a comment in Excel can be edited or deleted by
right-clicking on the cell.
In Calc, there is no context menu selection for inserting a note. A note is inserted by the menu
path Insert > Note.
To edit an existing note in Calc, the same menu path is used (Insert > Note).
To delete a note in Calc, either:
•

Select Insert > Note, then highlight and delete the contents of the note; or

•

Press Delete; then from the dialog box, uncheck all items except for Notes.
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Text to columns

Text to columns
You cannot do this in Calc without external help. See http://ooomacros.org/user.php#104183
for a macro to do this.

Solver
There is no equivalent in Calc to the Solver add-in for Excel, but a working macro prototype
has been developed and is available from
http://www.openoffice.org/issues/show_bug.cgi?id=8808.
Another option is available from http://solver.linuxml.com/index.html.

Charts
Chart types that Excel provides that Calc does not:
•

Bar of pie converts to a 2D - columns - normal

•

Pie of pie converts to a 2D - columns - normal

•

Radar filled converts to line radar

•

Radar with markers–converts to 2D–net–normal but counter clockwise rather than
Excel’s clockwise

•

Bubble charts convert to XY charts

•

Surface Charts convert to Deep 3D bar charts

Other charting issues include:
•

Charts are slower to update in Calc than in Excel.

•

There are fewer axis options, such as no option for having an inverted y axis (negative
at top towards positive at bottom).

•

The data must be contiguous, with the labels in the first row or column.

•

To change the range, click on the border of the chart so that it is selected (green
selection points) > Right Click > Modify Data Range...

Number formats
There is no “accounting” format (with the currency symbol at the left edge of the cell).
There is no predefined option for bracketing negative numbers. Use a custom format such as
“$#,##0.00_);[RED]($#,##0.00)”.
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Use of Autosum feature
The Autosum feature (invoked by clicking on the upper-case Greek sigma) works slightly
differently in one respect in Calc than in Excel.
For either Excel or Calc, you can select an empty cell, generally just below the bottom of a
range containing numbers to be summed (or to the right of a range of numbers to be
summed). When the Autosum button is clicked, Excel or Calc will propose a range to be
summed, which in many cases, is in fact the range the user intended. If this is the correct
range, pressing Enter will enter the SUM function into the cell. If the proposed range is not
what the user intended, the user can highlight the range desired, then press Enter. There is no
difference between Excel and Calc when using the Autosum as described above.
In Excel, you can also first highlight the range to be summed plus one additional blank cell,
then click Autosum. The SUM function will then be entered in the previously blank cell. This
use of Autosum is not available in Calc.

Grid lines and other view settings
In Excel grid lines on the screen are a property of a Worksheet. In Calc it is a document-wide
property, set as follows:
Tools > Options > OpenOffice.org Calc > View

Hidden rows
There is no “select only visible rows” command. Selecting a block of cells with hidden rows
and deleting will delete the hidden rows as well. Work-around: select each visible row
manually before deleting. See IannzGotoSpecial.sxc available from
http://homepages.paradise.net.nz/hillview/OOo/ for a macro that can select only the visible
cells.

Navigator
OpenOffice.org’s Navigator (Figure 21) provides a hierarchical view of the objects that make
up a document. With the Navigator you can view a listing of objects such as sheets, range and
database names, linked areas, graphics, OLE objects, notes and drawing objects. While it is a
convenient way to browse and select the various objects that make up a document, you can
also use it to copy cells or insert links into a spreadsheet from another document, or from a
sheet within the same spreadsheet. (See “Working across spreadsheets“ on page 99.)
The Navigator copies and inserts links using drag and drop. To use the Navigator to create a
link, the data to be linked must be defined as a named range within the source document. If
there are no named ranges within the source document, the Navigator will not list any
linkable items.
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Navigator

The Navigator also displays the objects and can link data from Excel spreadsheets.

Figure 21: The Navigator

Styles and Formatting window
Calc has two types of styles, cell and page. To display the Styles and Formatting window
(98), press F11 or select Format > Styles and Formatting. Right-click in the Styles and
Formating window to create, modify, or delete styles.

Figure 22: Styles and Formatting
window, showing built-in cell styles

Conditional formatting and styles
Conditional formating requires styles to be defined before selecting Format > Conditional
formatting.
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Function list
The Function list is a floating or dockable window that provides information about the
available functions. It is an alternative to Functions Wizard. To view it: Insert > Function
List.

Error values
Some functions in Calc return cryptic error messages like Err:503. To get a message that is
more meaningful you can select the cell with the error message then look at the right end of
the status bar. In this case it will show “Error: Invalid floating point operation” (for example,
division by zero).
A full description for each error message is given in the OpenOffice.org Help.

Working across spreadsheets, web pages and
database data
Working across spreadsheets
Calc’s Navigator can be used to copy or link to data from another spreadsheet (source).
To insert a link (or reference) to or copy a cell or range of cells with the Navigator:
1) Open the source and the target documents.
2) Open the Navigator from the target document. Use the Edit > Navigator command or
the F5 shortcut. Select the Drag mode you want to use (see ).
•

Insert as Hyperlink - creates a hyperlink back to the source file.

•

Insert as Link – insert a linked copy of the data in the target document.

•

Insert as Copy – copies the range to the target document, but does not link it to
the source range.

3) Select the source document from the box at the bottom of the dialog.
4) Browse to the Range names category and open it by clicking on the plus (+) sign. If
there are no named ranges in the source document there will be no ranges available for
insertion.
5) Select and drag the range you want to link to the target sheet.
Note

If the cell range in the source spreadsheet you want to insert in has not been defined
as a named range, define it by using the Define Names dialog accessible from the
Insert > Names > Define menu item, or use the Ctrl-F3 shortcut. Only named
ranges will appear in the Navigator.
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Figure 23: Linking between spreadsheets
To refer to the contents of cells in another spreadsheet document, or workbook, the syntax is
'url of other workbook'#$sheetname.cellrange. For example, on a Linux system:
'file:///home/hillview/Documents/Tests/Address.xls'#$Sheet1.A1
or, on a Windows system:
'file:///C:/Documents/Tests/Address.xls'#$Sheet1.A1
To input these links, you can:
1) Type in the formula up to the point where the link is required.
2) Select Window > [to select the desired document].
3) It is not obvious that this is working, but it is. Select the desired cell or range of cells.
4) Select Window > [select the original document].
5) Finish entering the formula.
What is disconcerting is that the value displayed is based on the value of the cell (or range of
cells) when the linked document was last saved.
So, to check it, save the linked document and update the link in the document (Edit > Links)
that contains the link.
Note

Links created using the prevous examples, including the Navigator’s drag and drop
method, do not update automatically.
To update them, use Edit > Links > [select the desired link] > Update. The update
works from the saved file – so if both files are open and the file that the link is based
on is updated, that file must be saved before updating the link.
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To have persistent updating of data between two spreadsheets, insert Dynamic Data
Exchange (DDE) links:
1) Select and copy the range of cells to be linked to.
2) Change to the spreadsheet that requires the link and select the
3) Open the Paste Special dialog, Edit > Paste Special and check the Link option (the
checkbox at the bottom left of the dialog).
4) Click OK to insert the DDE link.
These cells will have a persistent link to the contents of the other sheet and the values
returned can then be used in other formulas.

Links to HTML data or other spreadsheets
To link to data on the Internet:
1) In a browser navigate to the desired page.
2) Copy the URL.
3) In Calc, Insert > Link to External Data.
4) Paste in the URL.
5) This step is not obvious: press Enter, wait a moment and the bottom list box (called
Available tables/ranges) will show:
•

HTML_all (the entire page)

•

HTML_tables (all the tables on the page)

•

HTML_1 (each table consecutively numbered on the page)

6) Select the desired option from the list box.
7) Optionally check the Update every checkbox and specify how often to update.
The same process can be used for linking to data in spreadsheets.
Note

The source file must be saved before the update can take place. (In OOo, AutoSaves
overwrite the original file, so with AutoSaves turned on, this feature could be more
useful than it first appears.)

Links to database data
1) Display the Data source viewer (F4).
2) In the Data Explorer window, navigate to the desired table or query (if it is not visible
click Explorer on or off–left button in the Data source toolbar).
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3) Drag the table or query onto the sheet. (See the chapter “Getting Started with Base” in
the Getting Started guide for information about working with data sources, such as
registering the data source.)

Printing
Calc and Excel have similar printing functionality, but there are some important differences.
By default, Excel only prints the active sheet. By contrast, Calc will print all of the sheets in
the spreadsheet by default. To direct Calc to only print the active sheets, go to Tools >
Options > OpenOffice.org Calc > Print (see Figure 23). Check the box Print only selected
sheets. You can also check the box Suppress output of empty pages.
Note

We recommend selecting both boxes, to print only selected sheets and to suppress
output of empty pages.

Figure 24: Selecting print options
By default, if no print ranges have been specified anywhere within the spreadsheet, the print
range within a sheet will be chosen as a rectangular area from cell A1, to the lowest right cell
that has content.
If a print range has been specified within the spreadsheet, even on a different sheet, there is
no longer a default print range on any of the sheets. If no print range is established for a
particular sheet, nothing from that sheet will be printed.
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If you only want a portion of the spreadsheet to print, you must first specify a print range.
To define the print range (this is the equivalent of File > Page Setup > Sheet in Excel, first
three fields):
1) Format > Print Ranges > Edit.
2) In the Edit Print Ranges dialog (Figure 20), select the desired range for each of the
fields.
3) You can select noncontiguous areas for the print area, with each area being on a
separate page. Each area is separated by a semicolon.

Figure 25: Edit Print Ranges dialog
Calc provides a page-break view.
•

View > Page break preview

Other settings, such as whether to have grid-lines, are done through the page style:
•

Format > Page > Sheet

Print preview:
With Excel, a print preview will show what will actually be printed when finally sent to
the printer with the present settings in place. With Calc, the print preview will show the
print ranges from all of the sheets in the spreadsheet, even if it has been specified to only
print active pages.
To print:
1) File > Print.
2) Click Options to change the settings for suppressing blank pages or only the selected
sheets.
3) Other settings are the same as in Excel.
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Macros
Macros written in VBA for Excel do not work in Calc and macros written in StarBasic for
Calc do not run on Excel. Re-writing of macros is required when moving spreadsheets
between either application.
Some additional resources for writing Basic macros include:
“Porting Excel/VBA to Calc/StarBasic”
http://documentation.openoffice.org/HOW_TO/various_topics/VbaStarBasicXref.pdf
StarOffice 8 Programming Guide for BASIC,
http://docs.sun.com/app/docs/doc/819-0439
“Useful Macro Information for OpenOffice”, by Andrew Pitonyak,
http://pitonyak.org/AndrewMacro.odt
OpenOffice.org Macros Explained, by Andrew Pitonyak,
available from the publisher: http://www.hentzenwerke.com/catalog/oome.htm or from
various online booksellers.
Andrew Pitonyak’s web site for OOo macros: http://pitonyak.org/oo.php

Number recognition
Number recognition is where the user types in a “number” and the format of the cell changes
accordingly. The same thing applies to text copied from outside Calc and pasted into a
spreadsheet.
Rather than compare and contrast Excel with Calc, this section outlines how number
recognition works in Calc (which is slightly different from Excel).
Number recognition is dependent on locale. To set the default locale for OOo, use Tools >
Options > Language Settings > Languages.
To set the locale for particular cells, select the cells, right-click, and select Format > Cells >
Numbers tab > Language.

Default cell formats
The default cell formats are given in Table 15. To determine the default for a locale:
1) Select a cell that has not been formatted.
2) Select Format > Cells > Numbers tab (see Figure 26).
3) Click on the desired category.
4) Look for the default named in the Format and Format codes portion of the dialog.
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Figure 26: Formatting cells
Table 17. Default cell formats for different categories of cell formats.
Category

Default format

Format changed when
input is different
category?

Number

General

Yes

Date

Two defaults based on locale, one for date
only and another for date and time.

Yes

Time

Default for the locale

Yes

Boolean

TRUE or FALSE

Yes

Percentage

0.00%

No

Currency

Default for the locale

No

Scientific

0.00E+000

No

Fraction

# ?/?

No
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Input category
The input category is determined as shown in the following table.
Table 18: Input categories
Category

Nature of input

Examples
(based on
USA locale)

Function or
formula

Starts with an equals sign.

Boolean

True or false (case does not matter)

=A1+A2 or
=SUM(A2:A10)
True or
FALSE

Number

Digits only with optional decimal separator, optional
thousands separator, negative numbers expressed with
either a negative sign at either end or enclosed by
brackets.

1, 1.1, -1, (1)

Percentage

Same as for number but has a % at right end.

1%, -1%, (1)%
1.1% , 0.1%

Currency

Same as for Number but with the locale’s currency
symbol at either end.

$1, 1$, $(1),
(1)$, $1.1

Scientific

Same as for Number but can have E (case does not
matter) and then a power of ten.

1e1, 1E1, -1e1,
(1e1), (1e-1),
(1.2e1)

Fraction

Optional negative sign, some digits, a space, some
digits, a slash, some digits.

1 1/2, -1 2/3

Time

One or two digits, time separator for locale, one or two
digits, optional time separator for locale, optional
decimal separator for locale, more digits.

10:40, 1:30

Date

Most representations of dates. If the year is not given,
it is interpreted as being the current year, if the digits
for century are not given, it is determined by the
settings in Tools > Options > OpenOffice.org >
General. If the numbers given are not valid for the
locale, then input is interpreted as text. Examples
include: one or two digits, date separator for locale,
one or two digits (1/1); three sets of digits separated by
decimal separator (1.1.1); textual representations (1
Feb).

1/1, 1/1/5, 1.1.5,

Date and time

Input is in the form of (date) digits, date separator for
locale, a space, digits with time separator for locale.
As for dates, the numbers must be valid for the locale.

1/1/5 10:30

Text

Anything that does not meet the above criteria.

28/28
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1,123, -123.1

1 Feb, 1 Jan,
1 January
1 January 05
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Changing the cell’s format based on input
Calc works as follows:
1) First a category is worked out for the input.
2) If the input is a function and the current cell’s format is a default, that is, not explicitly
defined, then the cell’s format is determined by the hierarchy of the inputs to the
function. The order is dates, time, currency, percentage, scientific, fractions, and
numbers unless an input to a function is returning a value of a different type. Some
examples of this last exception:
•

A date plus a number returns a date, because date supersedes number in the
hierarchy.

•

A function like =Month() returns a number even though a date is used as the input.

else:
3) If the input category is boolean, then the cell’s format is changed to boolean. If the
input category is text, then the cell’s format does not change.
else:
4) If the cell format is Number–general, Date–default, Time–default, or boolean, and the
category of input belongs to a different category, then the cell’s format is changed to
the default for the input category.

Pasting values
A consequence is that, when copying text that contains dates and pasting into a Calc
spreadsheet, you can determine what the result is going to be. Suppose your default locale is
USA where the default date format is MM/DD/YY and the data that you are copying is in the
format DD/MM/YY (the European default). If you set the format of the cells that you are
going to paste the data into to date format DD/MM/YY, the dates will be correctly
interpreted; if you do not, it will not. You can then change the format of the cells to
MM/DD/YY to display the dates in USA format.
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Chapter 7
Differences in Use between
Impress and PowerPoint

Introduction

Introduction
This document builds on the information given in General Differences in Use between
OpenOffice.org and Microsoft Office by describing specific differences in use between
Impress and PowerPoint.
Impress has undergone a complete overhaul between OOo 1.1.x and OOo 2.0.

Accessing different views
Impress provides equivalent views to those provided by PowerPoint. The main difference is
that Impress gives you quick access to all of its views from the main window (Figure 27).
The main window has three parts: the Slides pane, Workspace, and Tasks pane. The Slides
pane allows you to do specific things to individual slides. The Workspace is where most of
the work is done to create individual slides. The Tasks pane contains a group of four tasks
which affect styles, the layout, animation, and transitions between slides in your presentation.

Figure 27: Main window of Impress
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Accessing different views

The views are summarized in Table 19.
In PowerPoint the buttons for quickly changing the view are in the bottom left corner. In
Impress the equivalent buttons are in the top center of the screen.
The view buttons have moved for OOo 2.0. They are now directly over the main
editing area.

In PowerPoint the Notes view is only accessible from the View menu. In OOo, the Notes view
is accessible at the top of the editing area.
To quickly access the Master Slide view in PowerPoint, you hold down the Shift key while
clicking on the Normal View button. This action can not be performed in OOo.
In previous versions of OOo, the master view could be accessed easily from a button
on the bottom of the window. Now, the only way to access and edit the master slide
is to select View > Master > Slide Master.

The easy access button for layers is no longer present in OOo 2.0. Arranging objects
between different layers is accomplished from the context menu.

Impress provides a Handout view for fine-tuning how handouts look. This is equivalent to
(but more flexible than) PowerPoint's Handout Master option.
Table 19. Comparison of view names between PowerPoint and Impress.
PowerPoint
name

Impress
name

Main use

Normal

Normal

To edit the contents of the slide; both text and
formatting.

Slide Sorter

Slide Sorter

To arrange the order of the slide show

Slide Show

Slide Show

Starts the presentation from the current slide

Outline

Outline

To edit the text, but none of the formatting.

Notes Page

Notes Page

To append notes to a slide

Master > Handout

Handout Page

To change the number and position of multiple slides
to be printed on a page

Master > Slide

Master > Slide

To place and modify those things that are consistent
in all slides in the presentation
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Color gradients and borders

Color gradients and borders
Impress does not support some of the formatting features that PowerPoint does. For example
it does not support three-color gradients, double and triple borders, or round-dotted borders.
When importing PowerPoint slides, Impress changes three-color gradients to two-color,
double or triple borders to single and round-dotted borders to square dots.
To improve the results of the import, make any necessary adjustments in PowerPoint before
importing files into Impress. Change three-color gradient fills to two-color. Change double or
triple border lines to a single border line with suitable width. The round-dotted border lines
that are mapped to rectangle-border lines, during import, will closely resemble the original
line style in PowerPoint so that manual editing should not be necessary.

Multimedia
Narration
Voice-over narration is not supported by Impress.
There are no settings for multimedia custom animations, such as the ability to play a sound
for the next few slides.

Sound
Sounds can be added in Impress using Insert > Movies & Sound, however sounds only play
for the slide they associated with. You can not insert background music for the whole
presentation in Impress.

Chart animations
There is no facility in Impress for Chart Effects, as there is in PowerPoint, such as presenting
a series or category at a time. On import the charts simply appear. A workaround is to have
multiple copies of the chart with each one set up to display as desired.
A feature in OOo 2.0 can be selected from Insert > Animated Image to help in the creation
of chart animations. It also allows you to group several still images into one animated image.
Insert > Animated Image is a new feature that allows you to group several still
images into one animated image.
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Pack and Go

Pack and Go
This feature in PowerPoint allows a PowerPoint file to be saved to a CD, or split up over
several floppy disks, and assures that all related files are included. This feature does not exist
in Impress, nor can Impress open such files.
Impress can export a show to a Flash file. PowerPoint can not.

Fields
Impress date fields are exported as text, so they do not automatically update.
Fields are shown with a gray background when editing so that they are recognizable as fields.

Action settings and interaction
PowerPoint provides action settings (jump to slide, run program) for mouse overs. Impress
does not have that option except on mouse click. Therefore PowerPoint mouse overs get
mapped to mouse clicks. PowerPoint has an option for highlighting the object on mouse click
or mouse over; Impress does not have that so it gets ignored on import. However you can
click on Internet hyperlinks during a presentation.

Animating a slide show
Custom animations
Impress has custom animations that are equivalent to custom animations in PowerPoint.
Applying animations in Impress is very similar to PowerPoint.
In OOo 2.0 the terminology for animations has changed. What were Effects in OOo
1.1.x are now called Custom Animations in OOo 2.0.

To access custom animations select either Slide Show > Custom Animation or click on the
words Custom Animation in the task pane.
To add an animation, select the object to be animated and then click Add. A dialog box,
shown in Figure 28, appears.
OOo Impress 2.0 now has a task pane. From the task pane many of the common
formatting options can be accesseds: Master Pages (Slide Designs in PowerPoint),
Layouts, Custom Animation, and Slide Transition.
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Animating a slide show

Figure 28: Slide show custom animation dialog
You can choose between Entrance, Emphasis, Exit, and Motion Paths effects. If you scroll
down the list you will find Basic, Moderate, Exciting, and Special as categories effects.
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Animating a slide show

Differences in animation effects
On export or import of either Impress or PowerPoint files the names of the effects change.
However, the result and appearance are essentially the same. See Table 20.
In OOo Impress 2.0, you can have multiple animation types in one text box. In OOo
Impress 1.1.x, you were limited to only one animation type per text box.

Table 20. Comparison of animation effects names between PowerPoint and Impress.

PowerPoint

Impress

Appear

Appear

Blinds

Venetian Blinds

Box

Box

Checkerboard

Checkerboard

Diamond

Diamond

Crawl

Fly In Slow

Dissolve

Dissolve

Flash once

Flash Once

Peek

Peek

Random Bars

Random Bars

Spiral

Spiral In

Split

Split

Stretch

Stretchy

Strips

Diagonal Squares

Swivel

Swivel

Wipe

Wipe

Zoom

Zoom

Random effects

Random Effects
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Animating a slide show

Slide transition effects
In the same way that object animations have a mapping between PowerPoint and Impress,
slide transitions also have different names between the programs as summarized in Table 21.
Table 21. Comparison of slide transition names between PowerPoint and Impress.

PowerPoint
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Impress

Blinds Horizontal

Venetian Blinds Horizontal

Blind Vertical

Venetian Blinds Vertical

Box In

Box In

Box Out

Box Out

Checkerboard Across

Checkerboard Down

Checkerboard Down

Checkerboard Across

Cover Down

Cover Down

Cover Left

Cover Right

Cover Right

Cover Left

Cover Up

Cover Up

Cover Left Down

Cover Left Down

Cover Right Down

Cover Right Down

Cover Left Up

Cover Left Up

Cover Right Up

Cover Right Up

Cut

No equivalent transition

Cut through Black

No equivalent transition

Dissolve**

Dissolve

Fade Through Black

Fade Through Black

Random Bars Horizontally

Random Bars Horizontal

Random Bars Vertically

Random Bars Vertical

Split Vertical In

Split Vertical In

Split Vertical Out

Split Vertical Out

Strips Left Down

Random Bars Vertical

Strips Left Up

Random Bars Vertical

Strips Right Down

Random Bars Vertical

Strips Right Up

Random Bars Vertical

Uncover Down

Uncover Down

Uncover Left

Uncover Left

Push Right

Push Right
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Fitting text to a frame
Fitting text to the frame, or a text box, in the two programs behaves differently. In
PowerPoint, the program automatically resizes the font proportionally as the text exceeds the
size of the text box.
In Impress, if the option Fit to frame has been selected, the program allows text to be typed
outside of the text box. When you select another object, signifying that typing has finished,
Impress resizes the text as if it were resizing a picture. This often leads to compressed and
unattractive text.
The best way to avoid this effect is to keep the text within the text box.
To change the Fit to frame property in Impress:
1) Click on the text frame to select it.
2) Right-click on the text area and select Text in the pop up menu. The Text dialog opens.

Figure 29: Changing the "Fit to frame" property
3) On the Text tab are options to automatically adjust frame size or font size as follows:
•

Fit width to text resizes the text to fit the width of the drawing or the text object.

•

Fit height to text resizes the text to fit the height of the drawing or text object.

•

Fit to frame resizes the text to fit the entire area of the drawing or text object. To
be able to check this option the other two options must be unchecked.
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Chapter 8
Customizing OpenOffice.org

Customizing toolbars

Customizing toolbars
Using the Alt key to drag icons on the toolbars does not work in OpenOffice.org 2.0. The
other concepts for customizing the toolbars in OpenOffice.org are similar to those in
Microsoft Office. The specific steps are outlined below.

Customizing toolbars
You can get to the toolbar customization menu in three ways:
•

Tools > Customize > Toolbars tab.

•

Click the arrow at the end of any toolbar and choose Customize Toolbar.

•

View > Toolbars > Customize > Toolbars tab (same as Microsoft Office).

Figure 30. The Toolbars tab of the Customize window
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Customizing toolbars

However, rather than dragging buttons onto the toolbar as is required in Microsoft Office, you
need to use the Customize dialog (Figure 30):
1) OpenOffice.org <name of the program (example: Writer)> Toolbars: Activate the
drop-down list to select the toolbar.
2) Toolbar Content: The checkboxes determine whether the button gets displayed or not.
3) The Move Up or Move Down buttons change the order.
4) If the function you require is not already listed for the toolbar, use the Add button to
insert it.
5) Use Modify for things like changing an icon, renaming, or restoring the default
settings.
Note

There is no in-built tool-button editor. To use a custom icon, save it to the
{install path}/share/config/symbol directory in *.bmp format. OOo
automatically searches this directory for new icons each time the Customize Buttons
dialog is opened. Custom icons must be 16 x 16 pixels in size and cannot contain
more than 256 colors.

Creating a new toolbar
To create a new toolbar:
1) Select Tools > Customize > Toolbars tab.
2) Click New to display a dialog where you can name the new toolbar. Click OK.
3) Customize the new toolbar as above.

Customizing menus
Customizing menus is not significantly different in OOo than in Microsoft Office. The
specific steps are outlined below. You can even set the menu font to be the font used by the
system.

Customizing menu content
To customize menu content:
1) Select Tools > Customize > Menus tab (Figure 31).
2) In the Save In drop-down list, choose whether to save this changed menu for the
application (for example, Writer) or for a selected document.
3) In OpenOffice.org <name of the program (example: Writer)> Menus, select the
menu you want to customize in the Menu drop-down list.
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Customizing menus

Figure 31. The Menus tab of the Customize dialog
To add a function:
1) Menu Content: Select the top level menu entry.
2) Click the Add button.
3) Select in the Add Commands dialog the new menu item using the Category and
Command list boxes.
4) Click Add to insert that function into the menu. When finished, click Close.

Customizing the menu font
The font used in OOo for menus is different from that used in Microsoft Office, which is the
system font. If you want to change the font to the one used in Office:
1) Tools > Options > OpenOffice.org > View.
2) Check Use system font for user interface.
3) Click OK.
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Customizing shortcut keys
Customizing shortcut keys requires a different procedure from that used in Microsoft Office.
In OOo use the following steps:
1) Tools > Customize > Keyboard tab.
2) On the Keyboard tab of the Customize dialog (Figure 32), select the desired shortcut
key in the top list box labeled Shortcut keys.

Figure 32. Defining keyboard shortcuts for applying styles
3) Select the Category, for the command, and the actual Function in the bottom list
boxes.
4) In the top right corner of the dialog, select whether the shortcut key is to be OOo-wide
or just for the current application (Writer for example).
5) Click Modify.
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Customizing shortcut keys

Note

The Alt key is not available for shortcut keys. A macro that overcomes this
limitation is in AltKeyHandler.sxw, available from
http://homepages.paradise.net.nz/hillview/OOo/.

Customizing word entry and editing
AutoCorrect/AutoFormat
A feature in OOo is the ability to have exceptions for AutoCorrect/AutoFormat rules. For
example, you can have “Correct TWo INitial Capitals” in operation but exclude situations
where two capitals are desired, like OOo. To set up exceptions:
1) Tools > AutoCorrect.
2) Click on the Exceptions tab (Figure 33).

Figure 33: Exceptions tab of AutoCorrect dialog
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Customizing word entry and editing

Undo and redo
To specify how many “undos” are available:
Tools > Options > OpenOffice.org > Memory > Number of steps.

Checking spelling
To set up the Spellcheck options in OpenOffice.org, use:
Tools > Options > Language Settings > Writing Aids
The Spellcheck options are consistent across all OOo applications.
Note

Unlike the default dictionaries, custom dictionaries are not compressed. Using too
many custom dictionaries, or those containing more than 1000 entries, reduces
performance while proofing.

Installing other language dictionaries
To install dictionaries of other languages select File > Wizards > Install new dictionaries.
An OOo document will open with links to different languages that you can install. Follow the
prompts to install them.

Security settings
To set up virus protection for macro and Java security settings, use:
Tools > Options > OpenOffice.org > Security
For other security-related issues, see Password Protection and Privacy Options in the chapter
“General Differences in Use between OpenOffice.org and Microsoft Office”.

Personal settings
To find out where these customizations are stored, use:
Tools > Options > OpenOffice.org > Paths
The dialog shows that the information, by default, is stored in a folder called “user”.
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Storing configurations in a template

Storing configurations in a template
This section describes how to store changes to menus, keyboard shortcuts, the status bar and
toolbars in a template so that the customizations are automatically loaded when you work on
a document based on that template.
1) Create and save the template that is to have the configurations saved into it. A back-up
of the template, without the configuration changes, is a good precaution too.
2) Make the desired changes to the configuration. (See “Customizing menus”,
“Customizing toolbars” and “Customizing shortcut keys” above.) Note that any
changes you do not want as standard will have to be undone.
3) Tools > Customize.
4) At each step of customization of the template, that is for each tab of the dialog that you
want to change, choose the desired template (the one first created and saved in step 1)
and click Save.
5) Overwrite the file—the warning message that is displayed can be ignored.
6) Undo the pre-existing changes that are not wanted (as was noted in step 2).
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